Search found 82 matches

by timo_karvinen
Wed Oct 14, 2015 2:58 pm
Forum: Zend Server for IBM i
Topic: File permissions
Replies: 2
Views: 2075

Re: File permissions

I think on newer versions of Zend Server on i the user profile that owns files created by PHP is QTMHHTTP (used to be NOBODY in old versions). Now QTMHHTTP by default has group profile NOGROUP, but unfortunately it also defines Owner-parameter as itself (*USRPRF) and not the group (*GRPPRF). If your...
by timo_karvinen
Wed Oct 14, 2015 1:26 pm
Forum: Zend Server for IBM i
Topic: ZendServer on port 10081 displaying rubbish
Replies: 7
Views: 4955

Re: ZendServer on port 10081 displaying rubbish

Well nice that you got it to work.
Still I think Zend should look into this, seems there's something wrong anyway.
Why it happened etc. seems it was compressing twice, or compressing and then not sending the information in headers that the data is compressed...

-Timo
by timo_karvinen
Wed Oct 14, 2015 10:33 am
Forum: Zend Server for IBM i
Topic: ZendServer on port 10081 displaying rubbish
Replies: 7
Views: 4955

Re: ZendServer on port 10081 displaying rubbish

I could be totally wrong, but the data shown in your screenshot resembles very closely what gzipped data would look like. So there could be some sort of problem with compression/decompression. If your browser allows, could you make it send this: Accept-Encoding: identity in it's request headers inst...
by timo_karvinen
Tue Sep 22, 2015 8:43 am
Forum: Zend Server for IBM i
Topic: Issue with CLCommandWithOutput
Replies: 1
Views: 1559

Re: Issue with CLCommandWithOutput

Just completely guessing here but maybe you don't have permissions to the user profile queried or the RTVUSRPRF command/program itself?

-Timo
by timo_karvinen
Tue Sep 08, 2015 9:06 am
Forum: Zend Server for IBM i
Topic: Trouble installing Composer on IBMi
Replies: 3
Views: 3811

Re: Trouble installing Composer on IBMi

Hi. PHP is kind of funny like that, it doesn't come bundled with root certificate file (at least the i variety, I'm not entirely sure about others). So you have to get your root certificate file separately, pretty common way is to go with Mozilla root certificate bundle. You can find the file and th...
by timo_karvinen
Mon Aug 10, 2015 2:07 pm
Forum: Zend Server for IBM i
Topic: Zend Server and IBM i V6R1 support
Replies: 4
Views: 3215

Re: Zend Server and IBM i V6R1 support

I tried to install 8.5 for testing on a machine with V6R1 and the installer said this can't be done. "Zend Server 8.5 does not support V6R1M0" So I installed 8.0.2 which is working fine so far. I was also frustrated that this info couldn't be found anywhere on the Zend web site. It would be really n...
by timo_karvinen
Mon Aug 10, 2015 1:55 pm
Forum: Zend Server for IBM i
Topic: zend_shm_cache_store from iSeries BATCH job
Replies: 7
Views: 3890

Re: zend_shm_cache_store from iSeries BATCH job

And a third way would be to make another php-script that uses CURL to retrieve the indented original page through your web server.
You can call this "proxy" script from shell / cli.

-Timo
by timo_karvinen
Mon Aug 10, 2015 1:41 pm
Forum: Zend Server for IBM i
Topic: zend_shm_cache_store from iSeries BATCH job
Replies: 7
Views: 3890

Re: zend_shm_cache_store from iSeries BATCH job

Hi. There are couple of ways you could approach this problem. One way is to make your own program that sends HTTP request through socket and (optionally) reads response from your web server. Scott Klement has nice "RPG IV Socket Tutorial" available. You can use this method for much more (reading res...
by timo_karvinen
Fri Mar 21, 2014 2:31 pm
Forum: Zend Server for IBM i
Topic: CURL Error: 60: SSL certificate problem
Replies: 2
Views: 3250

Re: CURL Error: 60: SSL certificate problem

If I remember correctly you have to set the capath also, even if you use full path to the file.
I have this in my configuration file:

// set CA certificate for cURL
ini_set('curl.capath', SHARED . '/cert/');
ini_set('curl.cainfo', SHARED . '/cert/cacert.pem');

SHARED is full path from root.

-Timo
by timo_karvinen
Mon Mar 10, 2014 9:59 am
Forum: Zend Server for IBM i
Topic: mail function not working after upgrade to V7R1
Replies: 2
Views: 2443

Re: mail function not working after upgrade to V7R1

Hi.

I'm not sure if this is the fix you are looking for, but I'd just like to make you aware that php.ini has smtp-server settings also.
So you could try setting smtp-server name in php.ini also.

See more details at:
http://www.php.net/manual/en/mail.configuration.php

-Timo