Search found 33 matches

by longnoz
Wed May 09, 2018 2:18 pm
Forum: Zend Server for IBM i
Topic: Library list issues
Replies: 2
Views: 1168

Re: Library list issues

Thanks We already had $obj->setOptions(array('stateless'=>true)); Upon further investigation, I noted that the program in question was implementing the toolkit in a function. The DB connection was not set as a global variable in the function, so the function was not seeing DB connection. Actually, i...
by longnoz
Mon May 07, 2018 3:05 pm
Forum: Zend Server for IBM i
Topic: cURL not working on ibm i
Replies: 1
Views: 1074

Re: cURL not working on ibm i

We found the problem. You have to create the *SYSTEM certificate store using Digital Certificate Manager (DCM) in order for the php server to know where to go when it is validating the certificate presented by the 3rd party web site
by longnoz
Wed Apr 25, 2018 10:35 pm
Forum: Zend Server for IBM i
Topic: cURL not working on ibm i
Replies: 1
Views: 1074

cURL not working on ibm i

Hi I have a php script that runs fine on this non-ibm-i server http://ibruno.ca/ProjectCURL4.php cURL Info: Array ( [url] => https://euroapi.2ship.com/api/Hold_V1 [content_type] => application/json; charset=utf-8 [http_code] => 200 [header_size] => 258 [request_size] => 777 [filetime] => -1 [ssl_ver...
by longnoz
Fri Apr 13, 2018 10:22 pm
Forum: Zend Server for IBM i
Topic: Library list issues
Replies: 2
Views: 1168

Library list issues

Hello We typically use db2_connect and pass a set of libraries in the i5_libl paramater. This works perfectly for our db2_exec commands (ie simple SQL) $db = db2_connect($serial_no,strtoupper($_SERVER['PHP_AUTH_USER']),strtoupper($_SERVER['PHP_AUTH_PW']),array('i5_libl' => 'LIBERTU SFALIBR QS36F', '...
by longnoz
Fri Dec 22, 2017 9:06 pm
Forum: Zend Server for IBM i
Topic: Character set issues - random garbage characters returned
Replies: 8
Views: 2978

Re: Character set issues - random garbage characters returne

That's great! It solved the problem at the server level. Thanks!
by longnoz
Fri Dec 15, 2017 5:46 pm
Forum: Zend Server for IBM i
Topic: Character set issues - random garbage characters returned
Replies: 8
Views: 2978

Re: Character set issues - random garbage characters returne

I was able to set up this same web site on a test server. I changed QCCSID to 37. It did not solve the problem. Help!

PS. The garbage characters change when I do CTRL-F5 vs F5 to refresh my page. Not sure if this is a clue
by longnoz
Wed Dec 13, 2017 9:31 pm
Forum: Zend Server for IBM i
Topic: Character set issues - random garbage characters returned
Replies: 8
Views: 2978

Re: Character set issues - random garbage characters returne

I forgot to mention that fast cgi has this: SetEnv="CCSID=1208" SetEnv="LANG=C" I have since changed the toolkit.ini file to use UTF-8. Still no improvement I have set both these values to 37 as per another thread I found. Still no improvement CGIJobCCSID DefaultFsCCSID I have read some many article...
by longnoz
Wed Dec 13, 2017 9:00 pm
Forum: Zend Server for IBM i
Topic: Character set issues - random garbage characters returned
Replies: 8
Views: 2978

Character set issues - random garbage characters returned

Hi We are working on an ibm i where the QCCSID value is 65535. And the database files have a CCSID of 500 (French). Our web pages that are served by the php engine, using the ibm i toolkit to access the database (db2_connect), are returning properly formatted data about 75% of the time. The other 25...
by longnoz
Wed Nov 29, 2017 4:41 pm
Forum: Zend Server for IBM i
Topic: Storing configuration (hangs forever)
Replies: 2
Views: 3311

Storing configuration (hangs forever)

Zend Server 9.1.1 build 114795 on IBM i 7.3 When first connecting with browser to http://serverip:10081, I go through agreeing license, choosing Production (Single Server), entering passwords and clicking Launch, the 'Please wait, storing configuration...' always shows (stuck there). If I refresh th...