Search found 14 matches

by hnagao
Wed May 26, 2010 8:38 am
Forum: Zend Server for IBM i
Topic: Can I install ZendCore and ZendServer ?
Replies: 9
Views: 6528

Re: Can I install ZendCore and ZendServer ?

Hi,

Thanks for your reply. I'll try to install and test.
by hnagao
Tue May 25, 2010 8:06 am
Forum: Zend Server for IBM i
Topic: Can I install ZendCore and ZendServer ?
Replies: 9
Views: 6528

Can I install ZendCore and ZendServer ?

hi, My question is very simple but it is very important for me. Can I install ZendCore for i and ZendServer for i into the single IBM i server ? And Can i use them at the same time? In order to test and migrate my PHP's contents from ZendCore to ZendServer, I want to use ZendCore and ZendServer on t...
by hnagao
Mon Jan 04, 2010 3:54 am
Forum: Zend Core for i5/OS
Topic: Performance tuning Tips around PHP environment
Replies: 6
Views: 6360

Re: Performance tuning Tips around PHP environment

Hi, Happy new year and thanks for your response. I've been using the ZF 1.9 series, and don't want to use the Platform because it's not free. Now I'm optimizing some problem codes in consuming performance cost, and things are gradually changing for the better. You may wish my success. Thanks a lot !
by hnagao
Thu Dec 24, 2009 1:00 am
Forum: Zend Core for i5/OS
Topic: Performance tuning Tips around PHP environment
Replies: 6
Views: 6360

Re: Performance tuning Tips around PHP environment

Hi, Thanks for your response. I've forgotten to say we have used Zend Framework mainly. But some codes use native PHP db2_connect or DB2_pconnect. I executed almost all of your suggestion. And then, each performance of SQL's single job with native code came up to my expectation. But when multiple re...
by hnagao
Tue Dec 22, 2009 4:13 am
Forum: Zend Core for i5/OS
Topic: Performance tuning Tips around PHP environment
Replies: 6
Views: 6360

Performance tuning Tips around PHP environment

Hi, I'm facing to improve the response time of multiple PHP requests at the same time. Our goal is to respond less than 2 seconds. I know the performance tuning is dependent on various factors, so it' s very difficult. Before tuning up at the beginning, Our environment is as follows: System i system...
by hnagao
Mon Dec 21, 2009 12:34 am
Forum: Zend Core for i5/OS
Topic: i5_spool_list problem !
Replies: 9
Views: 7570

Re: i5_spool_list problem !

Hi,

As the joblog says, i5_spool_list is calling a ZendCore's program EASYCOM in Zendcore library, after that it failed.
So, I think it might be a problem on EASYCOM program, after I saved Zendcore library on V5R4, I restored into V6R1.
After that, i5_spool_list works same as V5R4.
by hnagao
Wed Dec 16, 2009 7:52 am
Forum: Zend Core for i5/OS
Topic: i5_spool_list problem !
Replies: 9
Views: 7570

Re: i5_spool_list problem !

Hi,

I worked out a solution.
After I copied ZendCore 2.2.1 library from V5R4, I tried to test the same code on V6R1 installed 2.2.6. And then it works fine!

I couldn't find the cause, but my problem has been solved.

Thanks for your cooperation.
by hnagao
Fri Dec 11, 2009 7:29 am
Forum: Zend Core for i5/OS
Topic: i5_spool_list problem !
Replies: 9
Views: 7570

Re: i5_spool_list problem !

Hi, Yes, I tried to change user and other parameters. But it didn't work. This problem occured only at "i5_spool_list". Other i5 toolkit api work fine. Apache and PHP error log have never been generated after the execution. Only i5/OS job log says the following.(summary) MSGID TYPE SEV FROM PGM LIBR...
by hnagao
Thu Dec 10, 2009 3:58 am
Forum: Zend Core for i5/OS
Topic: Running a qshell command from PHP
Replies: 4
Views: 5601

Re: Running a qshell command from PHP

Hi, If you only want the output by executing 'ls' shell command, there is another way. You can get it by using 'shell_exec' command. please try the following code. <html> <body> <h2>shell_exec result</h2> <?php $rc = shell_exec("system 'STRQSH CMD(ls)' "); if (!$rc) { print 'error occured at shell_e...
by hnagao
Thu Dec 10, 2009 12:31 am
Forum: Zend Core for i5/OS
Topic: i5_spool_list problem !
Replies: 9
Views: 7570

Re: i5_spool_list problem !

Hi, luke. Are you fine? I tested my script under 2.6.6 update this week. But it doesn't work. The same error MCH3601 occurred . I'm wondering why my code doesn't work under my environment and it works under yours. I believe there are no differences except some PTF level. I repeat the same code works...