Search found 30 matches

by sal3415
Mon Jun 20, 2016 11:29 pm
Forum: Zend Studio
Topic: Zend Studio 13 + Debug Toolbar + Firefox 44
Replies: 10
Views: 10336

Re: Zend Studio 13 + Debug Toolbar + Firefox 44

Thanks cars, I appreciate the suggestion; however, I had hoped for an alternative solution that doesn't require disabling signature validation for all Firefox extensions. Browser security is perhaps more important today than at any time in the past.
by sal3415
Mon Jun 20, 2016 6:44 am
Forum: Zend Server
Topic: require_once fails during debug
Replies: 10
Views: 6357

Re: require_once fails during debug

Despite confirming via error logs that it is looking in the right place, I decided to prepend the first require_once with the full path set via call: $APP_ROOT = dirname(__DIR__); . The result of this was a 500 Internal Server Error, and after confirming all was correct, extracted the following from...
by sal3415
Mon Jun 20, 2016 5:47 am
Forum: Zend Server
Topic: require_once fails during debug
Replies: 10
Views: 6357

Re: require_once fails during debug

Scratch that, it's stopped working again. Nothing changed, one minute I stepped through the code to completion, then I immediately started stepping through again and it hit upon this require_once nonsense again. I restarted the computer to see if that helped, to no avail. Looks like it might be a bu...
by sal3415
Mon Jun 20, 2016 4:38 am
Forum: Zend Studio
Topic: Debug Configuration PHP Server Changes
Replies: 1
Views: 1290

Re: Debug Configuration PHP Server Changes

The require_once component of this problem was fixed by removing all PHP servers within Zend Studio and re-adding them back as 'Remote Zend Server' instead of 'Local Zend Server' entries. The core problem still persists, in that each invocation of debug still changes the designated PHP server for th...
by sal3415
Mon Jun 20, 2016 4:33 am
Forum: Zend Server
Topic: require_once fails during debug
Replies: 10
Views: 6357

Re: require_once fails during debug (SOLVED)

This problem was caused by selecting "Local Zend Server" for each vhosts PHP Server in Zend Studio. Once I removed all the PHP servers in Zend Studio, restarted, added the Local Zend Server when prompted, and then manually created entries for my virtual hosts as "Remote Zend Server" instead, the pro...
by sal3415
Mon Jun 20, 2016 3:03 am
Forum: Zend Server
Topic: require_once fails during debug
Replies: 10
Views: 6357

require_once fails during debug

I have a strange problem that only occurs during debugging a project, where require_once statements seem to fail with a Fatal Error. Changing them to require statements allows it to move past that particular problem and onto the next require_once statement, where it then fails. If accessed without d...
by sal3415
Mon Jun 20, 2016 2:54 am
Forum: Zend Studio
Topic: Incorrect Server Detected with ZRay Debug
Replies: 0
Views: 1057

Incorrect Server Detected with ZRay Debug

I have a number of virtual hosts enabled on my local Zend Server installation, and I have created PHP servers within Zend Studio for each of them. When I visit a page in my web browser and select debug page from the Zend ZRay Toolbar, it opens in the debug perspective in Zend Studio, however, it has...
by sal3415
Mon Jun 20, 2016 2:46 am
Forum: Zend Studio
Topic: Debug Configuration PHP Server Changes
Replies: 1
Views: 1290

Debug Configuration PHP Server Changes

I have a local Zend Server (v9/php7) with many vhosts, and I've accordingly set up each vhost as a Local Zend Server within Zend Studio (v13.5 64bit). I am attempting to debug a given project with two debug configurations (one for index.php - /, and another for zf2.php - /contract/). Whenever I debu...
by sal3415
Mon Jun 20, 2016 1:44 am
Forum: Zend Server
Topic: Disabling Z-Ray in Zend Server 9 Development Edition
Replies: 2
Views: 1870

Re: Disabling Z-Ray in Zend Server 9 Development Edition

I am experiencing this problem also. While it is understandable that Selective cannot be chosen, it is quite another that Disabled cannot be set. I think this counts as a bug.
by sal3415
Tue Jun 14, 2016 12:19 am
Forum: Zend Studio
Topic: Zend Studio 13 + Debug Toolbar + Firefox 44
Replies: 10
Views: 10336

Re: Zend Studio 13 + Debug Toolbar + Firefox 44

I also miss the old Firefox toolbar. Haven't been able to even find a download link to it in quite a long time. The Z Ray pseudo-toolbar is nice, aids in debugging, but the Firefox toolbar was a lot more convenient for my workflow. I hope Zend will consider resurrecting it at some point - maybe even...