Search found 14 matches

by rcmartin
Mon Apr 22, 2013 7:04 pm
Forum: New Toolkit
Topic: disconnect() Results in Ending Code 30
Replies: 3
Views: 3706

disconnect() Results in Ending Code 30

I have an application that uses a stateful connection to start a user ibm i job and to execute commands/programs without any issues, but I have noticed that the user job is being ended with an End Code = 30 (abnormal) once the disconnect() function is executed (I was expecting an End Code = 0... and...
by rcmartin
Wed Apr 17, 2013 6:48 pm
Forum: New Toolkit
Topic: Sharing QTEMP RPG - DB2
Replies: 2
Views: 3396

Re: Sharing QTEMP RPG - DB2

I second the approach of SQL being added to the toolkit's functions, since this would allow a smoother transition for "native" ibm i developers to be productive sooner using this toolkit. Using PHP on this platform is great, but issues like this need to be resolved to encourage better adoption of th...
by rcmartin
Fri Feb 24, 2012 5:47 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

Erich, Your suggestion of supporting PHP code within HTML documents via the .phtml extension works like a champ within our current Zend Server instance - thanks so much for figuring this out. And I wholeheartedly agree with using a different extension for those HTML documents having PHP code embedde...
by rcmartin
Thu Feb 23, 2012 7:59 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

Yes, we are current with all related PTF's, and .PHP documents are processed as expected. Only the HTML documents with PHP code embedded within them result in the "no binding" 500 error (which execute fine using Zend Core 2.6.1).

I just don't know what else to try at this point.
by rcmartin
Thu Feb 23, 2012 3:21 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

Yes, there are multiple jobs running php-cgi.bin, and there are multiple copies of log files in the log and log/fastcgi directories. And our primary language is English as is logged (for some reason) as "PASE LANG en_US.." in a fastcgi/error_zfcgi.q* file. FYI - we never had a problem executing PHP ...
by rcmartin
Wed Feb 22, 2012 9:33 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

Hi Erich, I have the same lines of code in my Apache config, and here is my fastcgi.conf file: ; Static PHP servers for default user Server type="application/x-httpd-php" CommandLine="/usr/local/ZendSvr/bin/php-cgi.bin" StartProcesses="1" SetEnv="LIBPATH=/usr/local/ZendSvr/lib" SetEnv="PHPRC=/usr/lo...
by rcmartin
Tue Feb 21, 2012 5:29 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

Finally getting back to this - in the web server's error log I am seeing this message when requesting an HTML document with a PHP script (HTML documents without a PHP script render fine), which results in a 500 Internal Serer Error: [error] Can not find binding for type='text/html; charset=utf-8' pa...
by rcmartin
Tue Dec 13, 2011 5:50 pm
Forum: Zend Server for IBM i
Topic: apache works php scripts display as text
Replies: 19
Views: 12151

Re: apache works php scripts display as text

I know that I am resurrecting this old thread, but I am running into the same issue (trying to execute PHP within an existing HTML page). But when I tried using the AddHandler fastcgi-script .php .htm .html declaration in the httpd.conf file, I get a 500 Internal Server Error page when displaying an...
by rcmartin
Wed Aug 03, 2011 6:35 pm
Forum: Zend Core for i5/OS
Topic: DB test not working
Replies: 17
Views: 26771

Re: DB test not working

As a follow-up to this post - when I use a non-blank userid and password on the db2_connect() function (and therefore not having it execute using the NOBODY profile), it works fine. So I am assuming that there is some user count limitation re: db2 connections - if so, can anyone point me to this inf...
by rcmartin
Wed Aug 03, 2011 6:14 pm
Forum: Zend Core for i5/OS
Topic: DB test not working
Replies: 17
Views: 26771

Re: DB test not working

I know this is an old thread, but the described scenario now appears to be happening to me now as well, even when using the same test db2 connection script on an iSeries... which was working a few hours ago. This happened to me once before, and the only thing that fixed it was an IPL of the box. Bas...