Search found 38 matches

by davelhs03
Thu Feb 09, 2012 5:29 pm
Forum: Zend Server for IBM i
Topic: db2_bind_param not working
Replies: 17
Views: 14967

Re: db2_bind_param not working

I figured out my problem. I was missing the library list option (i5_libl) on db2_connect. After adding the library list my stored procedure appears to be working. $options = array('autocommit' => 'DB2_AUTOCOMMIT_OFF', 'i5_lib' => 'DEFAULTLIB', 'i5_libl' => 'ARLIB1 APLIB2 ACLIB3'); $db = db2_connect(...
by davelhs03
Wed Feb 08, 2012 11:33 pm
Forum: Zend Server for IBM i
Topic: db2_bind_param not working
Replies: 17
Views: 14967

Re: db2_bind_param not working

Anyone else still getting this issue? I'm trying to upgrade from Zend Core 2.6.0 to Zend Server for I 5.6 and I'm running into problems with db2_* functions and calling a rpg stored procedure with 3 IN parameters and 1 INOUT parameter. I'm starting to think I'll have to use the toolkit functions. I'...
by davelhs03
Wed Feb 08, 2012 4:32 pm
Forum: Zend Server for IBM i
Topic: Safely remove Zend Core for IBM i5/OS
Replies: 16
Views: 30010

Re: Safely remove Zend Core for IBM i5/OS

Will Zend Core 2.6.0 suffice or does it have to be 2.6.1 before you can uninstall it safely?
by davelhs03
Wed Aug 26, 2009 10:03 pm
Forum: Zend Core for i5/OS
Topic: db2_connect() Warning: Issue with driver_options.i5_commit
Replies: 0
Views: 1523

db2_connect() Warning: Issue with driver_options.i5_commit

Warning: db2_connect() [function.db2-connect]: i5_commit (DB2_I5_TXN_NO_COMMIT, DB2_I5_TXN_READ_UNCOMMITTED, DB2_I5_TXN_READ_COMMITTED, DB2_I5_TXN_REPEATABLE_READ, DB2_I5_TXN_SERIALIZABLE) in /usr/local/Zend/ZendFramework/library/Zend/Db/Adapter/Db2.php on line 182 I get that error with the followi...
by davelhs03
Thu Jun 25, 2009 3:14 pm
Forum: Zend Studio for IBM i
Topic: Is there a Zend Studio 7 Beta for I5?
Replies: 1
Views: 3325

Is there a Zend Studio 7 Beta for I5?

I see that there's a Zend Studio 7 beta just released. Is there on for the I5 Edition?
by davelhs03
Fri May 29, 2009 4:07 pm
Forum: Zend Core for i5/OS
Topic: Data from i5 is not translating to ascii (SOLVED)
Replies: 7
Views: 6708

Re: Data from i5 is not translating to ascii

Looks like an encoding issue. What are the datatypes of the fields in mike.inp35?

What character encoding (charset) are you using on the webpage? You'd find that in this tag

Code: Select all

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
by davelhs03
Tue May 26, 2009 3:21 pm
Forum: Zend Core for i5/OS
Topic: php.ini overwritten
Replies: 2
Views: 2161

php.ini overwritten

Anyone have a clue as to why my php.ini file would be replaced with just:

i5comm.port =
by davelhs03
Wed May 20, 2009 7:58 pm
Forum: Zend Core for i5/OS
Topic: DB test not working
Replies: 17
Views: 27487

Re: DB test not working

Yeah none of the links work... and http://www.zend.com/en/support-center/knowledge-base doesn't work when i try to search the knowledge base. Oh well, might be something on my end. Tried FF3 IE8 and Google Chrome.
by davelhs03
Wed May 20, 2009 2:19 pm
Forum: Zend Core for i5/OS
Topic: DB test not working
Replies: 17
Views: 27487

Re: DB test not working

shlomov,

Those links don't work. The pages are blank.