Search found 38 matches

by davelhs03
Thu May 14, 2009 9:11 pm
Forum: Zend Core for i5/OS
Topic: Stored Procedure (String Variable problem) DB2 UDB
Replies: 8
Views: 10943

Re: Stored Procedure (String Variable problem) DB2 UDB

Thanks, but i'm actually using the Zend Framework's Database classes [ Zend_Db_Adapter_Db2 and Zend_Db_Statement_Db2 ]. so its more like $configuration->database->adapter = 'DB2'; $db = Zend_Db::factory($configuration->database->adapter,$config); $this->_dbh = $db; // $this->_dbh is a Zend_Db_Adapte...
by davelhs03
Thu May 14, 2009 7:57 pm
Forum: Zend Core for i5/OS
Topic: Stored Procedure (String Variable problem) DB2 UDB
Replies: 8
Views: 10943

Re: Stored Procedure (String Variable problem) DB2 UDB

yeah, i initially tried to use the bind param, but it wasn't working for me. (viewtopic.php?f=64&t=589#p2418) Oh well I'll just use the work-around...
by davelhs03
Wed May 13, 2009 3:15 pm
Forum: Zend Core for i5/OS
Topic: DB test not working
Replies: 17
Views: 27486

Re: DB test not working

Whats the error Message?

Why are there "<" ">" in your host, username, and password?

should be able to connect using
$conn = db2_connect ("S1090C02","RUSS", "russ");
by davelhs03
Tue May 12, 2009 3:51 pm
Forum: Zend Core for i5/OS
Topic: Stored Procedure (String Variable problem) DB2 UDB
Replies: 8
Views: 10943

Stored Procedure (String Variable problem) DB2 UDB

I'm calling a stored procedure that uses 2 decimal values and 2 string values, but when i prepare and execute i don't get a result back when i'm expecting one. If i run the stored procedures on the i series navigator or by concatenating the variables into the SQL string it works and brings back a re...
by davelhs03
Mon May 11, 2009 9:12 pm
Forum: Zend Core for i5/OS
Topic: Using Zend Framework to connect to i5/OS
Replies: 8
Views: 8436

Re: Using Zend Framework to connect to i5/OS

shlomov wrote:A minor suggestion:
The Password for the DB2 functions should be entered as UPPER CASE!
Right!, Any suggestion about my current issue using the bindColumn and bindParam functions? or can you only pass the parameters through the execute method?
by davelhs03
Wed May 06, 2009 9:59 pm
Forum: Zend Core for i5/OS
Topic: $_SERVER['HTTPS']
Replies: 11
Views: 10455

Re: $_SERVER['HTTPS']

http://www.itjungle.com/fhg/fhg062707-story01-fig04.jpg - Sometimes pictures help to visualize the problem That's weird the RewriteRule should force 443 with the i5/OS HTTP Server, and the proxy (PASE Apache HTTP Server) should be on port 8000... So for some reason its not hitting the virtualhost th...
by davelhs03
Wed May 06, 2009 6:53 pm
Forum: Zend Core for i5/OS
Topic: $_SERVER['HTTPS']
Replies: 11
Views: 10455

Re: $_SERVER['HTTPS']

Not sure if this helps, but you could force HTTPS for all connections # test.example.com On Port 80 - Redirect to HTTPS <VirtualHost 10.1.1.20:80> RewriteEngine On RewriteRule ^/(.*)? https://%{HTTP_HOST}/$1 </VirtualHost> # test.example.com On Port 443 (HTTPS) <VirtualHost 10.1.1.20:443> ServerName...
by davelhs03
Wed May 06, 2009 2:52 pm
Forum: Zend Core for i5/OS
Topic: Using Zend Framework to connect to i5/OS
Replies: 8
Views: 8436

Re: Using Zend Framework to connect to i5/OS

Ok so i can connect now, but bindColumn and bindParam seem to not work......... Is there a disclaimer somewhere to tell me what to do and not to do? i.e. don't use PDO_IBM, don't use bindColumn or bindParam... I keep running into these zend framework components that just don't work with Zend PHP on ...
by davelhs03
Wed May 06, 2009 1:48 pm
Forum: Zend Core for i5/OS
Topic: Using Zend Framework to connect to i5/OS
Replies: 8
Views: 8436

Re: Using Zend Framework to connect to i5/OS

Thanks for the insight. You are correct, my username and password are lowercase and not upper case. After changing that it worked fine. I just wish the error message would of been more descriptive. Maybe zend can do a check for all caps when the DB2 adapter tries to connect, and throw an exception s...
by davelhs03
Tue May 05, 2009 10:11 pm
Forum: Zend Core for i5/OS
Topic: $_SERVER['HTTPS']
Replies: 11
Views: 10455

Re: $_SERVER['HTTPS']

Code: Select all

if($_SERVER['SERVER_PORT']=="80" )
{
     echo "HTTP";
}
if($_SERVER['SERVER_PORT']=="443" )
{
     echo "HTTPS";
}