Search found 23 matches

by greg7308
Fri Nov 13, 2015 2:08 am
Forum: Zend Server for IBM i
Topic: phpinfo() not working in Admin Console.
Replies: 1
Views: 1977

Re: phpinfo() not working in Admin Console.

yeah same here. But on two LPARS it works, and on one it doesn't, can't see why myself.
by greg7308
Mon Sep 21, 2015 10:55 pm
Forum: Zend Server for IBM i
Topic: Issue with CLCommandWithOutput
Replies: 1
Views: 1516

Issue with CLCommandWithOutput

Any idea why this works $cmdString = 'RTVJOBA JOB(?) USER(?) NBR(?) CURUSER(?) SYSLIBL(?) CURLIB(?) USRLIBL(?) LANGID(?) CNTRYID(?) CCSID(?N) DFTCCSID(?N) OUTQ(?)'; $Result = $Tks->CLCommandWithOutput($cmdString); and this does not? $cmdString = "RTVUSRPRF USRPRF(?) GRPPRF(?)"; $Result = $Tks->CLCom...
by greg7308
Thu Jul 23, 2015 6:11 am
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

Thanks Sheldon - awesome info there. I tried that but it still failed, but I did manage to finally get an error that shows a CCSID conversion issue from code page 65535. I totally gave up on GETSPLF in the end, and wrote my own ... just using the CLCOMMAND from XTOOLKIT to copy the splf to a temp PF...
by greg7308
Wed Jul 22, 2015 3:20 am
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

Hi Sheldon, I am still having issues with this ... also recently upgraded to the lates release. same deal.

Where exactly did you change the xecuteQuery() to db2_execute() ?

Cheers
Greg
by greg7308
Wed Apr 01, 2015 1:10 am
Forum: PHP Questions / Hints
Topic: initiate pcom session?
Replies: 3
Views: 3902

Re: initiate pcom session?

Thanks Mark, will follow that idea as suggested ...
by greg7308
Mon Mar 30, 2015 2:53 am
Forum: PHP Questions / Hints
Topic: initiate pcom session?
Replies: 3
Views: 3902

initiate pcom session?

Is it possible to have a web page on the ibm i with a link to start a pcom green screen session on the users PC? I can do this via VB for apps, but that is already running "locally". I tried something like this but it didn't like the COM object ... https: / / msdn . microsoft . com /en-us/library/d5...
by greg7308
Thu Oct 16, 2014 2:58 am
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

Thanks for the help everyone. Sorted now. Seems I was initiating a session on the default QTMHHTTP profile which was retained, and later it was not authorised to use a splf.
Doh!
by greg7308
Wed Oct 08, 2014 1:18 am
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

Thanks for the link Scott,

Finally grabbed the authorization.php file. For some reason it never installed when I loaded the xmlservice stuff - odd.

It appears to be authority related then, will follow up on that line ...

Cheers
GC
by greg7308
Tue Sep 23, 2014 11:03 pm
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

Thanks for the replies! I'll look into a bug report then, was kinda hoping I wasn't the first with this. If anyone has a working script to do the same as this it would be appreciated. http : / / files dot zend dot com/help/Zend-Server-IBMi/zend-server.htm#spooled_files_methods.htm%3FTocPath%3DAPI%25...
by greg7308
Mon Sep 15, 2014 12:33 am
Forum: Zend Server for IBM i
Topic: GetSPLF failing to perform the CPYSPLF function
Replies: 24
Views: 11940

Re: GetSPLF failing to perform the CPYSPLF function

*BUMP*

Anyone got any ideas on this or should I open a bug report with Zend?

Cheers
GC