Compatibility Wrapper issue on program call

Post Reply
kenberg
Posts: 11
Joined: Sun Jan 03, 2010 8:12 pm

Compatibility Wrapper issue on program call

Post by kenberg » Wed Jun 03, 2015 2:40 pm

I have posted a message to the Zend ticket site and they recommended also posting here. Zend ticket number is 53450.

I am trying to convert from and old version of Zend using the old program call methods from Aura. I am going to use the CW until some future time when can update the code to do the call to XML toolkit directly.

When I downloaded a month or so ago downloaded the most current version at the time:

PHP Version 5.6.5

Zend Server Version: 8.0.2
Zend Framework: 1.12.10, 2.3.4
IBMi Toolkit: 1.5.0
Build: 95060

I have added the necessary include at the top and also the i5_output after the program call.

In the attachment test_php.txt is a testing code (extracted from the actual code) sample that is not working at this time.

Working on ticket with Rod at Zend, Rod indicated trying to increase the plug size. I went directly to 15M to avoid not setting large enough and still getting same error. Log data is in the attachment for xmltoolkit_log.txt

At this point just not sure where to go to resolve this problem. Any assistance would be appreciated.
Attachments
test_php.txt
(3.08 KiB) Downloaded 247 times
xmltoolkit_log.txt
(6.32 KiB) Downloaded 238 times

scottgcampbell
Posts: 187
Joined: Wed Apr 22, 2009 2:29 pm
Location: Edmonton, AB, Canada

Re: Compatibility Wrapper issue on program call

Post by scottgcampbell » Wed Jun 03, 2015 4:34 pm

Just as a quick test can you change

Code: Select all

array ("name"=>"ACCOUNT", "io"=>I5_OUT, "type" => I5_TYPE_PACKED,
 						"length"=> "9,0"),</parm> 
to

Code: Select all

array ("name"=>"ACCOUNT", "io"=>I5_OUT, "type" => I5_TYPE_PACKED,
 						"length"=> "9.0"),</parm> 
and see if you still get the error, just changing 9,0 to 9.0
Maybe it is an issue with the separator not being recognized in the toolkit?

Scott

Post Reply