Compatability Wrapper Tier 2 Issue

Post Reply
stewartm
Posts: 18
Joined: Thu May 17, 2012 3:14 pm
Location: Coleraine, N.Ireland

Compatability Wrapper Tier 2 Issue

Post by stewartm » Fri Sep 11, 2015 5:09 pm

Hi,

I've been testing Zend Server on Linux ClearOS with connection to an iSeries using the XML Toolkit. It's all been looking good and I've successfully tested an RPG program call using the Call_RPG_example.php test script (using $ToolkitServiceObj->PgmCall....).

However, I have lots of PHP code migrated from the iSeries that uses Easycom's 'i5_program_call'.

My question is can the Compatability Wrapper be used in a non-iSeries environment, or do I need to re-write all my PHP program calls to work in the Linux environment. I can't seem to find the cw error log but I get this when I include cw.php:
Fatal error: Using $this when not in object context in /usr/local/zend/var/libraries/PHP_Toolkit_for_IBMI_i/1.5.0/library/ToolkitService.php on line 1962

Zend Server: 7
XMLSERVICE:1.9.2
PHP Toolkit: 1.5.0
DB2 Connect Personnel Edition v10.1

Thanks
Mark

Post Reply