V6 - GUI is blank

General discussion forum for the Zend Server

V6 - GUI is blank

Postby justi7843 on Thu Feb 14, 2013 4:19 pm

I upgraded from the the CE v5 to v6 but can't even access the GUI. I've managed to track it down to this error in the zend_server_ui.log

2013-02-14T14:44:41+00:00 ERR (3): Failed retrieving license directives from ZS blueprint

This is running on my local laptop installation running Win XP as I wanted to give it a whirl before putting it on our development server. I noticed that after installing 6, 5 was still in add/remove programs so I uninstalled 6 but it wouldn't let me remove 5 so I reinstalled 5 and then uninstalled that again to try and tidy it up but I have since reinstalled 6 but still get the same error.

Any ideas?
justi7843
 
Posts: 2
Joined: Thu Feb 14, 2013 3:52 pm

Re: V6 - GUI is blank

Postby zvika on Sun Feb 17, 2013 9:47 pm

Hello Justin

I have been informed that upgrade of ZS 5.6 CE to ZS 6.0 was not reading the initial setup because of a bug in the installer, creating a second setup and hence more issues with configuration.

To try and resolve the issue at hand, I would advise to check services.msc, stop ZSD service, rename the file gui.db under "C:\Program Files (x86)\Zend\ZendServer\data\db" and starting ZSD service again. This should recreate the GUI data from existing configuration and will hopefully restore the GUI to working condition.

If this fails, the other option we can suggest at the moment is to copy the configuration files (etc folder) and remove 5+6, restart Windows and install a fresh copy of Zend Server 6.
After ZS 6 is working as expected, you can save the initial configuration and import whatever configuration you require from your backup.

We are working on a fixed installer for ZS 6 to properly identify ZS 5.6 CE prior to upgrade.

Please let me know any results / questions.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 794
Joined: Sun Dec 14, 2008 9:48 am

Re: V6 - GUI is blank

Postby justi7843 on Thu Feb 21, 2013 10:11 am

Good Morning.

I have tried that but still get the same error. Deleting the DB file did not work and I have also tried totally removing all Zend Server products from my PC, restarting, removing all files and settings as well and reinstalling but I still get this error.

Code: Select all
2013-02-21T08:50:22+00:00 ERR (3): Failed retrieving license directives from ZS blueprint
2013-02-21T08:50:22+00:00 ERR (3): exception 'ZendServer\Exception' with message 'Failed retrieving license directives from ZS blueprint' in C:\Program Files\Zend\ZendServer\gui\module\ZendServer\src\ZendServer\Utils\ZemUtilsWrapper.php:54
Stack trace:
#0 C:\Program Files\Zend\ZendServer\gui\module\Application\Module.php(590): ZendServer\Utils\ZemUtilsWrapper->getLicenseInfo()
#1 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\ServiceManager\ServiceManager.php(478): Application\Module->Application\{closure}(Object(ZendServer\Permissions\AclQuery), Object(Zend\ServiceManager\ServiceManager))
#2 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\ServiceManager\ServiceManager.php(412): Zend\ServiceManager\ServiceManager->create(Array)
#3 C:\Program Files\Zend\ZendServer\gui\module\Application\Module.php(1016): Zend\ServiceManager\ServiceManager->get('ZendServer\Perm...')
#4 C:\Program Files\Zend\ZendServer\gui\module\Application\Module.php(631): Application\Module->initializeLimitedACL(Object(Zend\Mvc\MvcEvent))
#5 [internal function]: Application\Module->onBootstrap(Object(Zend\Mvc\MvcEvent))
#6 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\EventManager\EventManager.php(469): call_user_func(Array, Object(Zend\Mvc\MvcEvent))
#7 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\EventManager\EventManager.php(209): Zend\EventManager\EventManager->triggerListeners('bootstrap', Object(Zend\Mvc\MvcEvent), Array)
#8 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\Mvc\Application.php(147): Zend\EventManager\EventManager->trigger('bootstrap', Object(Zend\Mvc\MvcEvent))
#9 C:\Program Files\Zend\ZendServer\gui\vendor\ZF2\library\Zend\Mvc\Application.php(244): Zend\Mvc\Application->bootstrap()
#10 C:\Program Files\Zend\ZendServer\gui\public\index.php(12): Zend\Mvc\Application::init(Array)
#11 {main}
justi7843
 
Posts: 2
Joined: Thu Feb 14, 2013 3:52 pm

Re: V6 - GUI is blank

Postby zvika on Thu Feb 21, 2013 12:38 pm

Hi Justin,
Thanks for testing and updating us.

Please try the following:
A. if you have a ZS6 license, insert the license information directly into "C:\Program Files (x86)\Zend\ZendServer\etc\php.ini" and restart Apache.
B. if still failing to load license credentials from php.ini, delete gui.db as before, restart ZSD service and check if the license is accepted and GUI comes up.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 794
Joined: Sun Dec 14, 2008 9:48 am

Re: V6 - GUI is blank

Postby alan8292 on Tue Feb 26, 2013 5:31 pm

Hi there,

I'm experiencing the same issue. I installed v6 Free side-by-side, in a different folder with different ports to 5.6 and now I'm getting that 'Failed retrieving license directives from ZS blueprint'.

What license do I need to paste in php.ini?

Thanks
alan8292
 
Posts: 1
Joined: Tue Feb 26, 2013 5:29 pm

Re: V6 - GUI is blank

Postby zvika on Sun Mar 03, 2013 3:51 pm

Hi Alan

The installation instead of upgrade was a glitch, which will be fixed in the upcoming release.
The supported method for installation is one version per machine, even if by a bug or hack you can get 2 versions on board.

Please follow this path to get a fresh install and see if you can request a free license from the GUI or you should have any problems (you can also try step 2 above with a fresh install if failing).
You can backup any configuration files at this point if you need them as reference for new configuration of ZS 6.

1. remove Zend Server 6
2. delete any leftover directory items / folders
3. remove Zend Server 5 if still installed
4. again, delete any leftover directory items / folders
5. check registry for leftover installation keys (uninstall should have cleared those, just in case)
Windows 32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Zend Technologies\ZendServer
Windows 64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Zend Technologies\ZendServer
6. install Zend Server 6 and login to the GUI at http://localhost:10081

Let me know any results please.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 794
Joined: Sun Dec 14, 2008 9:48 am


Return to Zend Server

Who is online

Users browsing this forum: Google [Bot] and 4 guests