Broken Packages on Ubuntu 10

General discussion forum for the Zend Server

Broken Packages on Ubuntu 10

Postby qkfeto on Mon Apr 26, 2010 10:17 pm

Hi,

I'm trying to install Zend Server Comunity Editon on a Virtual Ubuntu 10, I need to make sure it works for when we set up our live server using ubuntu 10 next week.
I get the following error

The following packages have unmet dependencies:
php-5.2-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installable
php-5.2-mysqli-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installable
php-5.2-pdo-mysql-zend-server: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installable
E: Broken packages


And if I look for libmysqlclient I see the following:

i libmysqlclient-dev - MySQL database development files
v libmysqlclient15-dev -
i libmysqlclient16 - MySQL database client library
p libmysqlclient16-dev - MySQL database development files - empty transitional package

How can I make the installer work?

Best regards,
Nestor
qkfeto
 
Posts: 1
Joined: Mon Apr 26, 2010 10:14 pm

Re: Broken Packages on Ubuntu 10

Postby kilior on Tue Apr 27, 2010 3:17 am

Hi i have the same problem.

I install the .tar.gz version, that way is not under the ubuntu version control and lose the updates of components, but work... well work if you don't need mysql, becaut that install don't have the support for mysql you must install and configure it.

Since i'm not a sysadmin and i made an abuse of apt-get for years i have troubles here.

I hope that someboy can make upgrade of the packs
kilior
 
Posts: 1
Joined: Tue Apr 27, 2010 3:11 am

Re: Broken Packages on Ubuntu 10

Postby massimilianoc on Tue Apr 27, 2010 1:11 pm

A question for @qkfeto.

What were the operations you ran to install Zend Server?

When you Ubuntu 10 do you mean the Beta version of 10.04?

Did you already had anything related to MySQL installed in your system before installing Zend Server?
Best regards,
Massi.
massimilianoc
 
Posts: 699
Joined: Thu Mar 12, 2009 11:58 am

Re: Broken Packages on Ubuntu 10

Postby massimilianoc on Wed Apr 28, 2010 4:18 pm

The problem will be fixed in the next release of Zend Server.
It is just a dependency problem due to the fact 10.04 is working with a higher version MySQL libraries than the ones Zend Server needs.


In the meantime, you can add to the old Karmic universe repo to your 'sources.list' and re-install Zend Server. This addition should make sure the dependency is satisfied.

Karmic Universe Repo:
Code: Select all
deb http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe
Best regards,
Massi.
massimilianoc
 
Posts: 699
Joined: Thu Mar 12, 2009 11:58 am


Return to Zend Server

Who is online

Users browsing this forum: No registered users and 4 guests