Ubuntu Lucid 10.04 Installation Problems

General discussion forum for the Zend Server
Post Reply
jon-em
Posts: 3
Joined: Sun Jun 06, 2010 4:35 pm

Ubuntu Lucid 10.04 Installation Problems

Post by jon-em » Sun Jun 06, 2010 4:43 pm

I am attempting to install Zend-CE on Ubuntu Lucid 10.04 and I am having installation problems, primarily with the libkrb53 library. This is a new installation from last week and Ubuntu Lucid uses the libkrb5-3 library instead, and I'm unable to install Zend-CE.

I have installed libmysqlclient15off as this came up in other forum discussions though this didn't help.

I have included the following in the /etc/apt/sources.list as well.

deb http://repos.zend.com/deb/ce ce non-free
deb http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe


I've followed the Zend installation guide and I get the following error:

# aptitude install zend-ce
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
libpq4 php-imap-zend-ce
The following NEW packages will be installed:
libaio1{a} libframework1-zend-ce{a} libicu36{a} libmhash2{a}
liboci-zend{a} libpng3{a} lighttpd-zend-ce{a} php-bcmath-zend-ce{a}
php-bz2-zend-ce{a} php-calendar-zend-ce{a} php-ctype-zend-ce{a}
php-curl-zend-ce{a} php-data-cache-zend-ce{a} php-debugger-zend-ce{a}
php-exif-zend-ce{a} php-fcgi-zend-ce{a} php-ftp-zend-ce{a}
php-gd-zend-ce{a} php-gettext-zend-ce{a} php-intl-zend-ce{a}
php-json-zend-ce{a} php-ldap-zend-ce{a} php-mbstring-zend-ce{a}
php-mcrypt-zend-ce{a} php-mhash-zend-ce{a} php-mime-magic-zend-ce{a}
php-mysqli-zend-ce{a} php-oci8-zend-ce{a} php-optimizer-plus-zend-ce{a}
php-pdo-mysql-zend-ce{a} php-pdo-oci-zend-ce{a} php-pdo-pgsql-zend-ce{a}
php-pgsql-zend-ce{a} php-posix-zend-ce{a} php-soap-zend-ce{a}
php-sockets-zend-ce{a} php-sqlite-zend-ce{a} php-tidy-zend-ce{a}
php-tokenizer-zend-ce{a} php-xmlreader-zend-ce{a}
php-xmlwriter-zend-ce{a} php-xsl-zend-ce{a} php-zem-zend-ce{a}
php-zendutils-zend-ce{a} php-zip-zend-ce{a}
php5-common-extensions-zend-ce{a} sqlite{a} zend-ce zend-ce-doc{a}
zend-extensions-ce{a} zend-framework-ce{a} zend-gui-ce{a}
0 packages upgraded, 54 newly installed, 0 to remove and 4 not upgraded.
Need to get 40.5MB of archives. After unpacking 158MB will be used.
The following packages have unmet dependencies:
php-imap-zend-ce: Depends: libkrb53 (>= 1.4.2) which is a virtual package.
libpq4: Depends: libkrb53 (>= 1.4.2) which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
libpq4 [Not Installed]
php-imap-zend-ce [Not Installed]
php-pdo-pgsql-zend-ce [Not Installed]
php-pgsql-zend-ce [Not Installed]
php5-common-extensions-zend-ce [Not Installed]
zend-ce [Not Installed]

Score is -9836

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done



# aptitude install zend-server-ce-php-5.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Couldn't find any package whose name or description matched "zend-server-ce-php-5.3"
Couldn't find any package whose name or description matched "zend-server-ce-php-5.3"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done


# apt-get install zend-ce php5-common-extensions-zend-ce php-imap-zend-ce
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php-imap-zend-ce: Depends: libkrb53 (>= 1.4.2) but it is not installable
php5-common-extensions-zend-ce: Depends: php-pdo-pgsql-zend-ce but it is not going to be installed
Depends: php-pgsql-zend-ce but it is not going to be installed
E: Broken packages

I have the following Zend packages installed:
# dpkg --get-selections | grep zend
libapache2-mod-php5-zend-ce install
libzend-framework-php install
php-dev-zend-ce install
php-mysql-zend-ce install
zend-base-ce install
zend-framework install
zend-framework-bin install

# dpkg --get-selections | grep krb5
libgssapi-krb5-2 install
libkrb5-3 install
libkrb5support0 install


Assistance would be greatly appreciated.

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Ubuntu Lucid 10.04 Installation Problems

Post by jess04 » Mon Jun 07, 2010 7:24 am

Hello,

First, please update you sources list to include:

Code: Select all

deb http://repos.zend.com/zend-server/deb server non-free
What you have is a very old repo.

Secondly, in order for the installation to succeed on Ubuntu 10.4 [Lucid], you will need to include the repo but I see you already have them. Are you sure this is Ubuntu 10.4 and not 9.10?

In addition, if you want to install the php-5.2-extra-extensions-zend-server or php-5.3-extra-extensions-zend-server packages, you'll need the updated packages attached here:
viewtopic.php?f=44&t=6361

Of course, all these issues are fixed in the next version, to be synced to repos.zend.com soon.

Please let me know if you require further assistance,
May the source be with you,

Jess Portnoy

jon-em
Posts: 3
Joined: Sun Jun 06, 2010 4:35 pm

Re: Ubuntu Lucid 10.04 Installation Problems

Post by jon-em » Mon Jun 07, 2010 2:08 pm

Great, that did the trick. I was following the installation instructions and the deb repo points to the old address that I used. I guess someone will need to update the documentation in the future.

jess04
Posts: 628
Joined: Thu Jan 15, 2009 3:37 pm

Re: Ubuntu Lucid 10.04 Installation Problems

Post by jess04 » Mon Jun 07, 2010 2:50 pm

Hello,

Glad to hear it worked.
In regards to documentation, can you refer me to the HREF in question?

Thanks in advance,
May the source be with you,

Jess Portnoy

jon-em
Posts: 3
Joined: Sun Jun 06, 2010 4:35 pm

Re: Ubuntu Lucid 10.04 Installation Problems

Post by jon-em » Tue Jun 08, 2010 11:36 pm

Sure, it was from: http:\\static.zend.com\topics\Zend-Server-CE-Installation-Guide-V403-2.pdf

Post Reply