Zend Guard encoding incorrectly

General discussion on Zend Guard / Optimizer

Zend Guard encoding incorrectly

Postby andrewej on Fri Dec 14, 2012 11:46 am

Hi,

We have a large PHP application that is installed on multiple clients' servers, each with it's own license.

Until recently, this has all been working fine. We have been able to encode individual files using the existing product key, or generate a new license and it would work correctly with the existing files.

About a week ago, we encoded a few files for one of our clients, and on running them received the following message:
Warning: Wrong license type, license codes are not matching this host or license text has been altered.

Since then, we have tried encoding files for several of our other clients; for some clients it has worked correctly, for others we get the same message.

Similarly, if we generate a new license, the same clients will have the issue that it will not work with previously encoded files.

The only way we have been able to get round this is to re-encode the files, and generate a new license. The application is very large so we want to avoid having to re-encode the whole thing multiple times.

Any ideas what the problem could be?

We're using PHP 5.3 with Zend Guard 5.5 and ZendLoader. Nothing has changed that we are aware of in our set up.

Thanks,
Andrew
andrewej
 
Posts: 1
Joined: Fri Dec 14, 2012 11:31 am

Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests