Zend Guard Loader requires Zend Engine API version 220100525

General discussion on Zend Guard / Optimizer

Zend Guard Loader requires Zend Engine API version 220100525

Postby wonb1930 on Thu Sep 04, 2014 1:56 am

Hi guys, i'm from korean.
I just ask one question about Zend Guard Loader.

when installed Zend Guard Loader on Ubuntu 14.x, php 5.5.x (Package name; php5-fpm),
Zend prints sentences below.

Code: Select all
Zend Guard Loader requires Zend Engine API version 220100525.
The Zend Engine API version 220121212 which is installed, is newer.


I can't install Zend Engine API version 220100525.

How can I install Zend Engine API version220100525??
please help me ;(
wonb1930
 
Posts: 1
Joined: Thu Sep 04, 2014 1:45 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby zvika on Thu Sep 04, 2014 9:43 am

Hi

PHP 5.5 is not yet supported and we do not have releases of Guard and Guard Loader for it.

When there is a PHP 5.5+ support for Zend Guard, it will be updated in the system requirements and you will have additional download on the Guard web pages.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby ed8267 on Wed Nov 26, 2014 1:13 pm

Hi,

I am running Yosemite recently.

The solution for me was to install php 5.4 by Liip
search the internet for:
setting-up-php-mysql-on-os-x-yosemite

Best regards,

Ed
ed8267
 
Posts: 3
Joined: Wed Nov 26, 2014 12:55 pm

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby zvika on Thu Nov 27, 2014 12:08 am

Hi Ed,
Thank you for returning to post a solution to the community.
Enjoy!
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby jan3847 on Fri Dec 12, 2014 9:07 am

zvika wrote:Hi

PHP 5.5 is not yet supported and we do not have releases of Guard and Guard Loader for it.

When there is a PHP 5.5+ support for Zend Guard, it will be updated in the system requirements and you will have additional download on the Guard web pages.


1. Most servers are upgraded to PHP 5.6 now, and you still have support for 5.4 only...

2. As I understand if older servers will upgrade from PHP 5.2 to PHP 5.6 your customers will have to buy newer ZendGuard and re-encode projects, because ZendGuardLoader will not work with files encoded for PHP 5.2 (with old ZendGuard version). Am I right?
jan3847
 
Posts: 11
Joined: Fri Dec 12, 2014 8:54 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby zvika on Sat Dec 13, 2014 8:25 am

Hi Jan,
Thanks for your questions.

Most servers are NOT using PHP 5.6, maybe in a new code base without old dependencies, shiny startup which provides cloud services or intranets.
http://w3techs.com/technologies/details/pl-php/5/all

You should not expect PHP 5.2 code to work flawlessly without any warning / errors / fatal on PHP 5.6, there are verbose upgrade instructions on php.net to migrating to higher sub versions and you can see the problems live when using a PHP IDE / Lexical check.

About the encoder and runtime, at our current architecture you will need a new set for PHP 5.5/5.6 and if it comes within a new Guard version, and your subscription expires when it is released, you will have to renew to get a later version.

Hope this helps.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby jan3847 on Sun Dec 14, 2014 10:05 pm

zvika wrote:Hi Jan,
Thanks for your questions.

Most servers are NOT using PHP 5.6, maybe in a new code base without old dependencies, shiny startup which provides cloud services or intranets.

You should not expect PHP 5.2 code to work flawlessly without any warning / errors / fatal on PHP 5.6, there are verbose upgrade instructions on php net to migrating to higher sub versions and you can see the problems live when using a PHP IDE / Lexical check.

About the encoder and runtime, at our current architecture you will need a new set for PHP 5.5/5.6 and if it comes within a new Guard version, and your subscription expires when it is released, you will have to renew to get a later version.

Hope this helps.


Ok, all NORMAL servers are using PHP 5.6+. Page with statistics you have copied here is probably for "Hello world" pages, where no one cares about their data security. Who will use PHP 5.2 and PHP 5.3 (66.9% according to your link) while these versions are not supported anymore and have a lot of known critical security issues for both versions? BTW PHP 5.4 is also not supported (only security fixes for 8 more months).

When are you going to release newer version of ZendGuard and will it support php 5.6?
jan3847
 
Posts: 11
Joined: Fri Dec 12, 2014 8:54 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby zvika on Sun Dec 14, 2014 11:11 pm

Hi Jan

As much as I like shiny and modern PHP, our customers think otherwise, and we still support PHP 5.3/5.4 on very big sites (hello world? really?).

Moreover, PHP Frameworks keeps the code and site clean and secured and supporting those PHP versions as minimal requirements.
Also, Zend provides LTS for PHP 5.3 and 5.4 for longer than you forsee - this is not because we like to keep customers on old PHP versions, its because what works and provides income, keeps working until there is a critical requirement needs upgrading, and that is also scheduled for several months ahead on big sites / backend systems.

[UPDATE] Regarding ETA for PHP 5.5+5.6 support in Guard, we are working on a release targetting Q1 2015 [UPDATE]
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Guard Loader requires Zend Engine API version 22010

Postby jan3847 on Mon Dec 15, 2014 8:11 am

zvika wrote:[UPDATE] Regarding ETA for PHP 5.5+5.6 support in Guard, we are working on a release targetting Q1 2015 [UPDATE]



Thank you! Will be waiting for it
jan3847
 
Posts: 11
Joined: Fri Dec 12, 2014 8:54 am


Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 6 guests