Encoding issue on ZendEncoder (segmentation fault)

General discussion on Zend Guard / Optimizer

Encoding issue on ZendEncoder (segmentation fault)

Postby adamsrl on Mon Dec 01, 2014 4:25 pm

Hello,
we stumbled upon a strange behaviour: the encoder seems to fail when more than 127 variables are enountered before a get_class() call and the result is a php crash (in both apache and cli mode).
We tried both Zend Guard 5.5 and 6.0 for Linux (same result)
Source file is attached.

CentOS (Linux version 2.6.32-131.0.15.el6.x86_64)
PHP 5.3.3
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

Before encoding:
[root@develop2 public_html]# php TestClass.php
Hello World

After encoding:
[root@develop2 public_html]# php TestClass.php
Segmentation fault (core dumped)
Attachments
TestClass.was.php.now.is.txt
Obviously the original extension was .php
(2.66 KiB) Downloaded 196 times
adamsrl
 
Posts: 2
Joined: Tue Dec 21, 2010 2:39 pm

Re: Encoding issue on ZendEncoder (segmentation fault)

Postby zvika on Sun Dec 07, 2014 9:16 am

Hi Adamsri,

Thank you for reporting this. To properly address this, please open a support ticket at http://support.zend.com
You can refer to this forum post to make sure it is updated with any result / workaround, if anyone else also gets this specific scenario and needs a solution.

Thanks!
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am


Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 2 guests