Does Zend Guard 7 support php 5.6.5 ?

General discussion on Zend Guard / Optimizer

Does Zend Guard 7 support php 5.6.5 ?

Postby kenn892 on Sat Apr 11, 2015 5:57 am

# /opt/php/bin/php -v
Failed loading /opt/php/lib/php/extensions/no-debug-zts-20131226/Zend/ZendGuardLoader . so: /opt/php/lib/php/extensions/no-debug-zts-20131226/Zend/ZendGuardLoader .so: undefined symbol: executor_globals
Failed loading /opt/php/lib/php/extensions/no-debug-zts-20131226/Zend/opcache . so: /opt/php/lib/php/extensions/no-debug-zts-20131226/Zend/opcache .so: undefined symbol: sapi_globals
PHP 5.6.5 (cli) (built: Feb 8 2015 12:55:24)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies
kenn892
 
Posts: 3
Joined: Sat Apr 11, 2015 5:55 am

Re: Does Zend Guard 7 support php 5.6.5 ?

Postby zvika on Sun Apr 12, 2015 10:38 am

Hello
Zend Guard Loader requires PHP NTS (non-thread-safe) and when loaded under Apache, use Prefork MPM.
Have you followed the README instructions in the Zend Guard Loader package?
Can you post the first section from phpinfo, about your PHP configuration?
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Does Zend Guard 7 support php 5.6.5 ?

Postby kenn892 on Tue Apr 14, 2015 9:48 am

I followed this link

http: //files. zend. com/ help/ Zend-Guard/ content/ installing_zend_guard_loader.htm

Fist section of phpinfo , many thanks

System Linux localhost.localdomain 2.6.32-504.3.3.el6.x86_64 #1 SMP Wed Dec 17 01:55:02 UTC 2014 x86_64
Build Date Feb 8 2015 12:53:26
Configure Command './configure' '--prefix=/opt/php' '--with-apxs2=/opt/httpd/bin/apxs' '--with-mysql' '--with-mysqli' '--with-curl' '--with-mcrypt' '--enable-mbstring' '--enable-fpm' '--with-xmlrpc' '--enable-soap' '--enable-zip' '--with-openssl' '--with-zlib-dir' '--with-png-dir' '--with-freetype-dir' '--with-jpeg-dir' '--with-vpx-dir' '--with-gd' '--with-tidy' '--enable-pcntl'
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path /opt/php/lib
Loaded Configuration File /opt/php/lib/php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20131106
PHP Extension 20131226
Zend Extension 220131226
Zend Extension Build API220131226,TS
PHP Extension Build API20131226,TS
Debug Build no
Thread Safety enabled
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar, zip
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls, tlsv1.0, tlsv1.1, tlsv1.2
Registered Stream Filters zlib.*, convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk
kenn892
 
Posts: 3
Joined: Sat Apr 11, 2015 5:55 am

Re: Does Zend Guard 7 support php 5.6.5 ?

Postby zvika on Tue Apr 14, 2015 2:14 pm

Hi
You have PHP TS, not NTS, therefore the NTS module cannot be loaded.
"Thread Safety enabled"

Please follow the instructions in the Zend Loader v.7 README,
but the online ref seems to be correct (currently not referring to Zend Server but I reported it missing for the documentation team to include).
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 986
Joined: Sun Dec 14, 2008 9:48 am

Re: Does Zend Guard 7 support php 5.6.5 ?

Postby kenn892 on Tue Apr 14, 2015 6:04 pm

Many thanks, i'll try
kenn892
 
Posts: 3
Joined: Sat Apr 11, 2015 5:55 am


Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 5 guests