php5.6 obfuscation level cannot change

General discussion on Zend Guard / Optimizer

php5.6 obfuscation level cannot change

Postby blas2773 on Tue May 12, 2015 10:39 am

Hello,

phpinfo() shows:
with Zend Guard Loader v3.3, Copyright (c) 1998-2014, by Zend Technologies
with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies
and in Zend Guard Loader table:
Obfuscation level 0

in php.ini is
zend_loader.obfuscation_level_support=3
apache restarted but no change in phpinfo.

apache 2.2.22
php 5.6.3
Zend Guard Loader (PHP 5.6 Runtime) - 64 bit
loader . so 69f6798d0f4d7a9dd152a79dc683719e (md5sum)
blas2773
 
Posts: 1
Joined: Tue May 12, 2015 10:15 am

Re: php5.6 obfuscation level cannot change

Postby zvika on Thu May 14, 2015 8:25 am

Hi

Thanks for the report!
AFAIK, the obfuscation level is just presentation and obfuscated code will still run normally.
Do you have a sample of L3 obfuscation PHP script to test?

If not, send me a PM I'll encode a simple test for you to load.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 983
Joined: Sun Dec 14, 2008 9:48 am

Re: php5.6 obfuscation level cannot change

Postby reza9342 on Fri Jul 15, 2016 12:30 am

zvika wrote:Hi

Thanks for the report!
AFAIK, the obfuscation level is just presentation and obfuscated code will still run normally.
Do you have a sample of L3 obfuscation PHP script to test?

If not, send me a PM I'll encode a simple test for you to load.



I have the same problem
what should I do?!
I attached my php .info
Attachments
New Text Document %282%29.txt
(30.45 KiB) Downloaded 172 times
reza9342
 
Posts: 2
Joined: Thu Jul 14, 2016 10:49 am


Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 1 guest