ZendGuardLoader error

General discussion on Zend Guard / Optimizer

ZendGuardLoader error

Postby ytfx4024 on Wed Apr 27, 2016 7:27 am

When I install ZGL on Centos7-php5.6 it gives me the following error upon php -m | grep Zend:
//note: the spaces before "so" are because, apparently, I can't post it without, because it thinks that it is a url... duh...

Failed loading /usr/lib64/php/modules/ZendGuardLoader. so: /usr/lib64/php/modules/ ZendGuardLoader. so: undefined symbol: zend_execute_ex

What is its problem?

The file is surely there, and mod is 777.

The php.ini part about ZGL is as follows:

[Zend]
; Enable ZendGuard loader module
zend_extension=/usr/lib64/php/modules/ZendGuardLoader. so
; Enables loading encoded scripts. The default value is On
zend_loader.enable=1
; Disable license checks (for performance reasons)
zend_loader.disable_licensing=0
; The Obfuscation level supported by Zend Guard Loader. The levels are detailed in the official Zend Guard Documentation. 0 - no obfuscation is enabled
zend_loader.obfuscation_level_support=0
ytfx4024
 
Posts: 1
Joined: Wed Apr 27, 2016 7:19 am

Re: ZendGuardLoader error

Postby zvika on Sun May 01, 2016 9:32 am

Hello
I'm assuming you picked the right binary arch for your system, i.e 64-bit package - correct?

There is no opcache loading in the ini directives you mentioned.
Please review the readme.txt in the Guard Loader package and make sure you override the PHP opcache.so with the packaged one.
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 985
Joined: Sun Dec 14, 2008 9:48 am


Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 2 guests