Failed to register and encoding after upgrading mac os

General discussion on Zend Guard / Optimizer
Post Reply
alle6323
Posts: 1
Joined: Tue Dec 12, 2017 12:11 pm

Failed to register and encoding after upgrading mac os

Post by alle6323 » Tue Dec 12, 2017 12:16 pm

Hi,
I have been using Zend Guard for half a year. But recently after I upgrading my mac to 10.13.2, it doesn't work.

I tried to reinstall the app, but it doesn't work. Now I cannot even register the license.
屏幕快照 2017-12-12 19.13.20.png
failed to register
屏幕快照 2017-12-12 19.13.20.png (121.19 KiB) Viewed 6253 times
/Applications/Zend Guard 7.app/Contents/Bundles/plugins/com.zend.guard.core.resources.macosx_7.0.0.201503261229/resources/GuardEngine --help
The operation has completed with bad exit status: 139

If I tried to encode my code, it also has the "139" error code.

Thanks for your help.

fran8890
Posts: 1
Joined: Sun Oct 05, 2014 2:12 pm

Re: Failed to register and encoding after upgrading mac os

Post by fran8890 » Tue Dec 19, 2017 10:17 am

Hi

I've already open a case at Roguewave Support Center and
they have already approved that it is a bug under High Sierra10.13.2.

They startet to investigate 7 days ago.
Bildschirmfoto 2017-12-19 um 10.16.04.png
Bildschirmfoto 2017-12-19 um 10.16.04.png (78.96 KiB) Viewed 6127 times
Best Regards
Frank

vask4616
Posts: 4
Joined: Thu Oct 23, 2014 11:54 pm

Re: Failed to register and encoding after upgrading mac os

Post by vask4616 » Tue Dec 19, 2017 12:51 pm

I have macOS High Sierra 10.13.2 and the same happened to me. We can not use Zenguard 7.0.0 any more.
Attachments
Screen Shot 2017-12-19 at 12.47.45.png
Screen Shot 2017-12-19 at 12.47.45.png (26.83 KiB) Viewed 6112 times

vask4616
Posts: 4
Joined: Thu Oct 23, 2014 11:54 pm

Re: Failed to register and encoding after upgrading mac os

Post by vask4616 » Tue Dec 19, 2017 12:59 pm

Also, in ZendGuar 6, every time we need to installed from dmg, then registerd.
If the ZendGuard 6 is registered already, it shows the error attached.

vask4616
Posts: 4
Joined: Thu Oct 23, 2014 11:54 pm

Re: Failed to register and encoding after upgrading mac os

Post by vask4616 » Tue Dec 19, 2017 1:04 pm

Attachement
Attachments
Screen Shot 2017-12-19 at 12.51.59.png
Screen Shot 2017-12-19 at 12.51.59.png (88.37 KiB) Viewed 6099 times

chri1549
Posts: 5
Joined: Thu Oct 31, 2013 4:03 pm

Re: Failed to register and encoding after upgrading mac os

Post by chri1549 » Sat Jan 06, 2018 7:15 pm

Any update?
I tried to install the new Beta of Mac OSX - 10.13.3 Beta (17D29a)
But there is no change, I am unable to encode files, because of receiving the error:

/Applications/Zend Guard 7.app/Contents/Bundles/plugins/com.zend.guard.core.resources.macosx_7.0.0.201503261229/resources/GuardEngine --xml-file /Users/username/Zend/workspaces/ZendGuardProjects/projectname/guard.xml
The operation has completed with bad exit status: 139

thom7418
Posts: 1
Joined: Fri Jan 26, 2018 2:37 pm

Re: Failed to register and encoding after upgrading mac os

Post by thom7418 » Fri Jan 26, 2018 2:47 pm

I've got a new mac ( 10.13.3) and a fresh installation of ZendGuard.
Can't import the lic "bad exit ..." if I try to put in the license file manually to /Applications/Zend\ Guard\ 7.app/Contents/Bundles/plugins/com.zend.guard.core.resources.macosx_7.0.0.201503261229/resources/...
I've got the error on encoding. Removing the file I'm able to use the test mode ....

chri6548
Posts: 14
Joined: Tue Feb 13, 2018 6:38 am

Re: Failed to register and encoding after upgrading mac os

Post by chri6548 » Mon Aug 27, 2018 1:06 pm

This is a common issue that everyone facing while registering. This article makes much easy to know about this problem and also helps to solve it in an easy way. Here each step is beautifully presented and thanks for this informative article. best internet provider

Post Reply