Zend Optimizer 3.3.3 not loading using PHP 5.2.11

General discussion on Zend Guard / Optimizer

Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby mheard on Tue Nov 10, 2009 8:17 pm

I'm testing a new installation of PHP to run a fresh install of Kayako SupportSuite and can't seem to get Zend Optimizer to load. phpinfo() shows the Zend Engine2 running but doesn't show the Optimizer loaded. I've checked php.ini and this is what it added to the bottom.

[Zend]
zend_extension_manager.optimizer_ts="C:\Program Files\Zend\ZendOptimizer-3.3.0\lib\Optimizer-3.3.0"
zend_extension_ts="C:\Program Files\Zend\ZendOptimizer-3.3.0\lib\ZendExtensionManager.dll"

I've uploaded an html archive of the phpinfo() output.

My running:
Windows Server 2003 R2
IIS 6.0
PHP 5.2.11
Zend Optimizer 3.3.3
mySQL 5.1

PHP installed in this location:
C:\Program Files\PHP

Zend Optimizer installed here:
C:\Program Files\Zend\ZendOptimizer-3.3.0

I'm using the Default Web Site in IIS:
C:\Inetpub

I'm stuck and don't know what to do next. Please help!
mheard
 
Posts: 1
Joined: Tue Nov 10, 2009 8:16 pm

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby kentatzend on Tue Nov 17, 2009 10:12 pm

3.3.3 will not work with PHP 5.2.10 oe 5.2.11 due to some changes in the lower level PHP code. We are in the process of trying to pull together a 3.3.9 release for Windows that should fix the problems. We hope to have this fairly soon.
User avatar
kentatzend
 
Posts: 1778
Joined: Thu Dec 11, 2008 1:08 pm

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby jmawebco on Wed Nov 25, 2009 3:24 pm

I am having the same issue with a flash content manager that requires the installation of zend optimizer. I have tried over 4 times now to install zend optimizer following the instructions in the user guide but continue to get the "Zend Optimizer not installed" message. If version 3.3.3 does not work with php 5.2.11 then what version of php does it work with? I tried installing the Community Edition of Zend Server and still get the same message so I'm at a loss as to what I can do to remedy this situation.

If anyone out there knows of a fix to this problem, other than going to a unix install, please make it available to me so I can get this whole mess fixed. I've been at this for about a month now so any help will be greatly appreciated.

Thanks in advance,

Jaime
jmawebco
 
Posts: 1
Joined: Wed Nov 25, 2009 3:17 pm

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby zvika on Sun Nov 29, 2009 10:38 am

Hello

As far as I know PHP 5.2.10 and up are not supported in Optimizer 3.3.3, so 5.2.9 might be the last PHP version for Windows running Zend Optimizer 3.3.3 until we release a new version.

Options are to install Zend Server (PHP 5.2 branch on CE) or use Linux with Zend Optimizer 3.3.9 on PHP 5.2.11
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 991
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby stevebardocz on Thu Dec 03, 2009 7:50 am

I'm having the EXACT same trouble. And have struggled with it for hours. I finally found something that leads me in the right direction and it ends with the option to either downgrade my PHP, find Zend Server CE (Does that mean for Windows CE?), or waiting for 3.3.9 (but no beta or estimated release date). So where do we go from here? You kind of lead us right toward a dead-end if we want an immediate solution.
stevebardocz
 
Posts: 1
Joined: Thu Dec 03, 2009 7:47 am

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby zvika on Thu Dec 03, 2009 8:02 am

Hello

2 Options seem to be at your disposal right now:
1. Use Windows PHP 5.2.9 stack (any) with Zend Optimizer 3.3.3
2. Use Zend Server (CE is community edition which is free) with Guard Loader (which replaces Zend Optimizer standalone for the Zend Server package)

Let me know if the above is sufficient for you to run / serve the PHP encoded applications you have
Zvika Dror
Zend Support Team
User avatar
zvika
Zend Global Support
 
Posts: 991
Joined: Sun Dec 14, 2008 9:48 am

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby btrotter on Fri Dec 18, 2009 12:09 am

I've got an install I need to have online like right now, but the only available downloads are 5.2.11 and 12. I can't find .9 anywhere! Help! Where's a reputable place to download PHP 5.2.9-1 for windows/IIS?

EDIT: I was getting impatient after googling and always being directed back to php.net and not having anything below 5.2.11 around- I even went into the /downloads/releases folder and couldn't find it. Apparently one needs to be patient enough to find the "information about older releases" inset box on the left and click there which takes you to a separate page: http://www.php.net/releases/
btrotter
 
Posts: 137
Joined: Sat Sep 05, 2009 9:11 pm

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby sockeatphpay on Tue Jan 26, 2010 7:35 pm

ZendOptimizer 3.3.3 seems not to work with PHP5.2.8 or 5.2.6
I tried in an XAMPP installation 1.7.0 on a simple Windows XP SP3
Or do I install something wrong? Only starting installer package an install to c:\xampp

phpinfo() shows
"This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies"

But if a coded file (ZendSafeGuard5.0.1 under SuSE 11.2 Linux)... only result is "Zend Optimizer not installed"

Perhaps something wrong in XAMPP package?

Any ideas?

Solution: viewtopic.php?f=57&t=1600
zend_optimizer.enable_loader = 0 must be
zend_optimizer.enable_loader = 1
sockeatphpay
 
Posts: 1
Joined: Tue Apr 28, 2009 11:06 am

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby btrotter on Mon Feb 01, 2010 7:40 pm

BUMP- where is Optimizer 3.3.9?

That site I set up with PHP 5.2.9 so our Zend Guard code would run is now furious with me because they're apparently out of PCI compliance which requires PHP 5.2.12 or higher.

I've put in a support ticket, but I need something today!

I've been very supportive of Zend and accepting of delays for PHP 5.3.0 support and am not targeting 5.3.0 functionality as a result, but being hit in the gut for running a very common version may be the straw that broke the camels back here.
btrotter
 
Posts: 137
Joined: Sat Sep 05, 2009 9:11 pm

Re: Zend Optimizer 3.3.3 not loading using PHP 5.2.11

Postby massimilianoc on Tue Feb 02, 2010 10:31 am

Zend Server is the answer for you.

It runs the PHP you need to be PCI compliant, if you install the Loader module you will be able to decode Zend Guard encrypted apps.

I guess you know where to find it, but anyhow here is the general link:
http://www.zend.com/en/products/server/

As you will see there is also there a link for the CE (Community Edition) version that may be enough for your needs.
Best regards,
Massi.
massimilianoc
 
Posts: 699
Joined: Thu Mar 12, 2009 11:58 am

Next

Return to Zend Guard / Optimizer

Who is online

Users browsing this forum: No registered users and 5 guests