Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:

General discussion on Zend Guard / Optimizer
Post Reply
many2601
Posts: 3
Joined: Wed Apr 22, 2009 3:21 pm

Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:

Post by many2601 » Wed Apr 22, 2009 3:40 pm

Hi Zenders,
I had problem running Zend on MAC OS Leopard . I installed Zend Optimizer successfully as it told me. but browser shows me that Zend Optimizer not installed.

Here are some output from info.php

Code: Select all

Loaded Configuration File	/private/etc/php.ini
PHP API	20041225
PHP Extension	20060613
Zend Extension	220060519
Debug Build	no
Thread Safety	disabled
Zend Memory Manager	enabled
Registered PHP Streams	php, file, data, http, ftp, compress.zlib, https, ftps
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
But php commandline giave this output:

Code: Select all

many$ /usr/local/php5/bin/php 
Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:  (null)

many$ php --ini
Configuration File (php.ini) Path: /etc
Loaded Configuration File:         /private/etc/php.ini
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)
and adds thoses line in php.ini:

Code: Select all

zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
zend_optimizer.version=3.3.3
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_optimizer.enable_loader = 1
thanks for your help
--many

websitedesignerx
Posts: 6
Joined: Fri Feb 06, 2009 4:49 am

Re: Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:

Post by websitedesignerx » Wed Apr 22, 2009 4:34 pm

I am not a MAC user and I have very little MAC experince but try checking to make sure your path to ZendExtensionManager.so is correct. for example mine would be:

/usr/lib/php/zend/ZendExtensionManager.so

Also make sure you check the spelling and if the path has capitals or lower case letter, or it might be a permissions issue.

many2601
Posts: 3
Joined: Wed Apr 22, 2009 3:21 pm

Re: Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:

Post by many2601 » Wed Apr 22, 2009 8:21 pm

thanks websitedesignerx for reply.
I checked path to this lib. and it is OK (/usr/local/Zend/lib/ZendExtensionManager.so)

Code: Select all

-rw-r--r--  1 root  wheel  37600 Apr 17 15:41 ZendExtensionManager.so
galaxy:lib many$ pwd
/usr/local/Zend/lib
And I did not see permission problems . Here is the process running apache on MAC OS X.

Code: Select all

galaxy:sbin many$ ls -la | grep apa
-rwxr-xr-x    1 root   wheel             3640 Sep 23  2007 apachectl
-rwxr-xr-x    1 root   wheel             3695 Sep 23  2007 apachectl-1.3
best

--many

many2601
Posts: 3
Joined: Wed Apr 22, 2009 3:21 pm

Re: Failed loading /usr/local/Zend/lib/ZendExtensionManager.so:

Post by many2601 » Thu Apr 23, 2009 6:33 pm

any suggestions ?

Post Reply