Can't disable comment formatting

General discussion on Zend Studio

Moderator: natalia_b_zend

Can't disable comment formatting

Postby dhinged on Mon Nov 12, 2012 8:55 pm

I comment single-line descriptive comments with a space and disabled code without a space like this:

// the following line of code is commented out
//$code = fetch_something();

It makes it easy to identify descriptive comments and re-enable disabled code. However, the latest Zend Studio (9.0.4 I'm using) automatically puts the space between the double-slashes and the text when I auto-format, and I see no option to set this. I can set spacing on everything else and have some basic options for commenting in Code Formatter, but not this specific thing. How do I get it to either ignore comment formatting or format it the way I want?
dhinged
 
Posts: 80
Joined: Thu Oct 22, 2009 5:12 pm

Re: Can't disable comment formatting

Postby zhaozhongwei on Thu Nov 15, 2012 3:21 am

hi you can ignore all comment formatting:
Perferences->PHP->Code Style->Formatter,create a new profile,then edit it,go to Comments tab,uncheck the first 3 checkbox.
zhaozhongwei
 
Posts: 2
Joined: Mon Aug 20, 2012 8:28 am


Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 5 guests