Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

General discussion on Zend Studio

Moderator: natalia_b_zend

Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

Postby bgoetze on Thu Aug 23, 2012 7:05 pm

Hi everyone,

I am experiencing some major problems with Zend Studio 9 and Mac OS 10.8 Mountain Lion:

On 10.8 Zend Studio (ZS) does not create the default Zend MVC project structure. However, I meant to have found a way of doing it. First I created a project using the zf.sh command using the console, then I created exactly the same project within ZS, same name, same place place. And voila, it shows the folders. But...

Any error within my project will not be handled by the debugger. The project works as long as there is not fault or syntax error in.

Another thing - I also tried to import console created projects but ZS did not recognize any project at all.

Finally I swiped my Mac and downgraded to 10.7.4 (please don't ask me about my mood...) and surprise: ZS9 works perfectly!

I assume an incompatibility between Mac OS X Mountain Lion and Zend Studio 9. Support is involved but unfortunately, their last reply is of August 13.

Best regards from Berlin
bgoetze
 
Posts: 2
Joined: Thu Aug 23, 2012 6:48 pm

Re: Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

Postby jlsphp on Fri Aug 24, 2012 3:10 am

I am experiencing exactly the same issue. I will not be returning to Lion, however, and am hoping for a fix now that the problem is documented.
jlsphp
 
Posts: 1
Joined: Fri Aug 24, 2012 3:08 am

Re: Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

Postby sylvie6713 on Tue Aug 28, 2012 7:24 am

Hi
Please check this post for a workaround: http://forums.zend.com/viewtopic.php?f=59&t=80148&p=160883#p160883
Let me know if it helped.

Regards
Sylvia
Sylvia Tancheva
QA Team, Zend
User avatar
sylvie6713
 
Posts: 298
Joined: Fri Feb 27, 2009 10:24 am
Location: Bulgaria

Re: Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

Postby bgoetze on Thu Aug 30, 2012 5:42 pm

Hi Sylvia,

finally ... it works!
Thank you.

Best regards
bgoetze
 
Posts: 2
Joined: Thu Aug 23, 2012 6:48 pm

Re: Do not upgrade to Mac OS 10.8 | ZS9 seems incompatible

Postby jasandoval on Sun Jan 06, 2013 5:06 am

I had the same issue, followed the instructions posted here, but no success.

So I took a look to the listening ports on my MBP w/OSX Mlion using
Code: Select all
sudo lsof -i | grep LISTEN
and noticed that Zend Studio listened only on IPV6, so I followed the instructions showed on http://forums.zend.com/viewtopic.php?f=59&t=6598 and restarted Zend Studio, still the same message.
But then looking closer to the Zend Studio ports listened, I noted that Zend St was actually listening to 4 ports, as follow

ZendStudi 2961 a-s 162u IPv4 0xb9ccd7d4b6b5bf89 0t0 TCP *:30000 (LISTEN)
ZendStudi 2961 a-s 163u IPv4 0xb9ccd7d4b6b5b851 0t0 TCP *:20080 (LISTEN)
ZendStudi 2961 a-s 175u IPv4 0xb9ccd7d4b0cadf89 0t0 TCP *:cslistener (LISTEN)
ZendStudi 2961 a-s 199u IPv4 0xb9ccd7d4ad6d5119 0t0 TCP *:28029 (LISTEN)

So I changed setting on Zendtoolbar on Firefox to the following:

AutoDetect Settings Enabled

Zend Studio Broadcast Port 20080

And Voila! All things started to work.

Hope this helps!
Best regards from Mexico.
jasandoval
 
Posts: 1
Joined: Wed Oct 14, 2009 1:33 am


Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 6 guests