Studio 9 Won't Open - Continue redirects to Zend.com

General discussion on Zend Studio

Moderator: natalia_b_zend

Re: Studio 9 Won't Open - Continue redirects to Zend.com

Postby wes_grant on Mon Jan 07, 2013 5:28 pm

wes_grant wrote:This appears to be caused by incorrect shutdown of the IDE.

I was able to resolve by going to my Zend/workspaces/DefaultWorkspace directory and removing (or renaming) the .metadata folder. Zend Studio should then start normally, creating a new .metadata folder.



...and after doing so, you lose all of your IDE settings, including projects. I've copied .plugins folders over one by one from the old .metadata folder to the new .metadata folder and seem to have a problem with the workspaces/DefaultWorkspace/.metadata/.plugins/org.eclipse.core.resources/.snap file. With everything else but this from the old folder copied over, the IDE starts. After I copy this file over, it doesn't.

It appears these are Eclipse snapshot files to help the IDE recover from the crashed session.

My projects are still missing after copying all folders over. Good time as any to upgrade to 10 I guess.
wes_grant
 
Posts: 12
Joined: Fri May 20, 2011 6:47 pm

Re: Studio 9 Won't Open - Continue redirects to Zend.com

Postby bpat1434 on Mon Jan 07, 2013 6:40 pm

You can just import the projects into your workspace instead of adding a new project again.
bpat1434
 
Posts: 4
Joined: Fri Nov 18, 2011 10:37 pm

Previous

Return to Zend Studio

Who is online

Users browsing this forum: Yahoo [Bot] and 8 guests