Zend folder in Windows XP roaming user profile

General discussion on Zend Studio

Moderator: natalia_b_zend

Zend folder in Windows XP roaming user profile

Postby peteruk on Thu Jan 10, 2013 1:34 pm

I am a new user of Studio 9 and have created a new project, including my PHP directories (on a mapped drive). Zend Studio 9 has created a folder in my user profile with a depth of 244 characters as the path for the deepest Zend file (example below).

My organisation saves our user profiles automatically and restores them whenever we log on (roaming profiles). This adds 29 characters to the start of the copy path, taking it over the windows MAX_PATH limit of 260 characters, giving me errors when login tries to fetch my roaming profile "DETAIL - The filename or extension is too long.". I can't work well without my user profile (sad face).

Question 1. How can I set an alternative location for the Zend folder to be saved? I always have a file server drive mapped, which could be used.

Question 2. Alternatively, what is the recommended way for me to include my current source in the project which won't cause the 244 deep path? It doesn't seem to appear until I include the source directories.

The 244 character path causing problems is:
Zend\workspaces\DefaultWorkspace\.metadata\.plugins\org.zend.php.framework.resource\resources\ZendFramework-1\library\Zend\Service\WindowsAzure\CommandLine\Scaffolders\DefaultScaffolder\resources\PhpOnAzure .Web\bin\add-environment-variables.cmd

Thanks in advance
peteruk
 
Posts: 6
Joined: Thu Jan 10, 2013 1:04 pm

Re: Zend folder in Windows XP roaming user profile

Postby amily1012 on Fri Jan 11, 2013 9:40 am

Thanks all the same
amily1012
 
Posts: 2
Joined: Sat Jan 05, 2013 11:05 am
Location: New York,United States

Re: Zend folder in Windows XP roaming user profile

Postby peteruk on Fri Jan 18, 2013 11:07 am

Thanks to Zend support, I have the answer which I will share here in case other new users find the same issue.

On a fresh install, Zend Studio (9.0.4) defaults the workspace to the Windows user profile (mine is in C:\Documents and Settings\username) and creates a folder named Zend there when the product starts up.

You need to change this location as soon as possible if you use roaming profiles, to avoid the problems noted in my post above.

You can do this by creating a folder in a new location (I was recommended to create it on a local drive), then in Zend Studio going to the File menu, then Switch workspace, then Other and selecting the new workspace folder you created. Studio will restart. The studio window title will now show the workspace folder that you selected.

I recommend that you now go to your Windows user profile and delete the Zend folder from there (Windows refused to delete mine, but I moved it elsewhere) if your profile is regularly backed up.

Peter
peteruk
 
Posts: 6
Joined: Thu Jan 10, 2013 1:04 pm


Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 2 guests