Zend Studio 9 debugging problem

General discussion on Zend Studio

Moderator: natalia_b_zend

Zend Studio 9 debugging problem

Postby ljthomas on Thu Jan 24, 2013 4:02 am

I am developing a PHP, Zend Framework based web application using the Zend Studio 9 IDE. Previously I was using the Flash Builder 4.5 for PHP to debug my application. However, I tried upgrading to Flash Builder 4.6 for PHP and that's when my problem started. They don't host FB 4.6 for PHP any longer. However, at one point there was a download for the application. I have since given up on using Flash Builder for PHP and was able to purchase a Zend Studio 9 license. Now I am using FB and ZS9 separately.

When I debug on either set of software I receive the same error message while trying to run a debug session on the PHP side. The error states, "A communication error occurred with the Zend Studio debugger due to an unfinished debug session. To reload the page click Refresh.". This seems to be occurring while my application is sending many asynchronous HTTP requests. It also seems to be random as to which requests actually send back the error message.

Based on the text I'm receiving and just continuously trying to get it to work, it seems while one debug request from the web server to the IDE has been initiated via Zend_Debugger is still active and a second HTTP request from the browser is received, the second HTTP request is rejected and the error message is sent back to the web browser.

My question is there any fix to this issue? It seems others have had this issue, but I haven't been able to find a solid answer to fixing the problem. Any help would be appreciated.

Thanks!
ljthomas
 
Posts: 2
Joined: Thu Jan 24, 2013 3:53 am

Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 4 guests