Cuting and Pasting in ZS10

General discussion on Zend Studio

Moderator: natalia_b_zend

Cuting and Pasting in ZS10

Postby oucil on Fri Feb 15, 2013 3:34 pm

I've just upgraded to the latest Zend Studio, release 10, and I'm running into a minor/growing annoyance that didn't exist in ver. 9. It's inconsistent so I can't tell what I'm doing to trigger it, but when I select and then "Cut" a block of code using CTRL-X, it's bringing up a little... for lack of a better name.... helper popup in the bottom right, light yellow background, with 3 Cut options. The annoyance is that where I would normally be able to just start navigating using arrow keys to where I'm going to Paste the block, the focus is in that helper forcing me to hit ESC to get out of it before I can paste.

At first it was "ok, wonder what I can do with that", but now based on how much I cut and paste, it's turned into a real PITA!!

Can someone please point me to where I can turn this off, I've hit the CTRL-SHIFT-L to bring up the shortcut prefs, but I don't see anything within the CTRL-X / Cut record that would be an obvious fix.

Any help would be greatly appreciated.

Kevin.
oucil
 
Posts: 23
Joined: Tue Aug 04, 2009 6:59 pm

Re: Cuting and Pasting in ZS10

Postby oucil on Sun Feb 17, 2013 8:00 pm

Just a quick update, I've found the cause, but still no solution. It's NOT when using CTRL-X, it's in fact when using SHIFT-DEL that the "helper" appears... I've attached a pic of it to illustrate what I'm seeing, this is in the lower right corner of the main editor window. Again, I would love to either be able to disable this functionality because I use SHIFT-DEL almost as often as CTRL-X, or if there's a really good reason for this and I don't know about it, I'd appreciate it if someone could enlighten me.

Thanks,

Kevin
Attachments
zendstudio.jpg
zendstudio.jpg (10.82 KiB) Viewed 429 times
oucil
 
Posts: 23
Joined: Tue Aug 04, 2009 6:59 pm

Re: Cuting and Pasting in ZS10

Postby oucil on Sun Feb 17, 2013 8:04 pm

Nevermind, answered my own question. For those interested, it's because there are three shortcuts assigned to the SHIFT-DEL keyboard combination, you can see them all by using the CTRL-SHIFT-L shortcut, highlighting the row that is in the current view then sorting by the "Binding" column. To eliminate the behaviour selector, just remove the other two unless of course you want to keep them.

Silly me.
oucil
 
Posts: 23
Joined: Tue Aug 04, 2009 6:59 pm

Re: Cuting and Pasting in ZS10

Postby marc6948 on Tue Feb 11, 2014 10:40 am

Thanks for posting the solution here. I ran into the same problem, a real WTF moment.
marc6948
 
Posts: 1
Joined: Tue Feb 11, 2014 10:38 am


Return to Zend Studio

Who is online

Users browsing this forum: No registered users and 4 guests