Problem debugging CLI script with Studio 9.0.4

General discussion on Zend Studio
Post Reply
colinflack
Posts: 11
Joined: Tue May 19, 2009 10:17 am

Problem debugging CLI script with Studio 9.0.4

Post by colinflack » Fri Aug 02, 2013 9:07 pm

I am using studio 9.0.4 in my local dev machine (fedora)
I have a separate local dev server setup (also fedora)
I have a port open on 10137 and ff studio toolbar says all is ok
And indeed I can debug a remote(local) web application without problem

But I cant seem to debug a CLI script.

If I attempt to debug a cli script from within the IDE I get this error:
The debug session could not be started
Please make sure that the debugger is properly configured as a php.ini directive
The script is in a web accessible folder on the server
That folder is also mapped to my desktop machine with sshfs and accessible there. I am accessing it with zend studio from the local mapped folder.

Window > Preferences > Debug > PHP Executable - is set as PHP 5.3.15 (CLI)
Window > Preferences > Debug > Enable Cli Debug - is checked

So whats going wrong?
and how to debug a cli script please?

thanks
ps I just logged and typed this out once. When I posted it the board told I wasnt logged in (I know my typing is slow but not THAT slow), then redirected me to a login page and unceremoniously trashed my typing. If you have some moderating going on to stop spam it isnt working, and I'll have 2 posts
Attachments
zsdebugerror.jpg
zsdebugerror.jpg (11.08 KiB) Viewed 1675 times

colinflack
Posts: 11
Joined: Tue May 19, 2009 10:17 am

Re: Problem debugging CLI script with Studio 9.0.4

Post by colinflack » Sat Aug 03, 2013 10:16 am

the debugger line in studio's copy of php.ini shows zend_extension = ./ZendDebugger.so
and it is there in same dir as php.ini, but obviously studio seems confused about where it is

So I tried copying it into the usual /usr/lib64/php/modules and amended the line in php.ini and it works

Post Reply