Page 1 of 1

Support for PHP 5.5

Posted: Tue Aug 06, 2013 6:25 pm
by boeve_webdesign
Hello,

Will ZS10 soon support PHP5.5?


regards

Re: Support for PHP 5.5

Posted: Sun Sep 15, 2013 10:18 pm
by heldchen
*bump*

Re: Support for PHP 5.5

Posted: Thu Sep 19, 2013 2:45 pm
by mark_garrett_goal
My guess would be for ZS 11 in a year or so. It took about that long for 5.4 to be supported (March 2012 - 5.4.0 released; Feb. 2013 - ZS 10) and 5.5 was released at the end of June. I'm sure most users would prefer for them to be working on bugs than new features - even something like 5.5 support - but sales people need NEW features to sale. That said, I'm using 5.5.3 myself for production and ZS 10 works fine. You will need to define your local binary for debugging purposes and I'm having to use Xdebug kinda awkwardly, but it's better than nothing!

Re: Support for PHP 5.5

Posted: Sat Sep 21, 2013 6:12 pm
by heldchen
i know one can use it with php 5.5, but the lack of code recognition, typeahead and debugging is annoying, to say the least.

isn't zend THE company behind php? competitors already released IDEs with full php 5.5 support for quite a while.

Re: Support for PHP 5.5

Posted: Sun Sep 22, 2013 11:25 am
by avi_levy
I need ZendDebugger.so extension for php 5.5.x so if someone in Zend or in community can help, just post a link

Re: Support for PHP 5.5

Posted: Wed Sep 25, 2013 7:32 pm
by mark_garrett_goal
avi_levy wrote:I need ZendDebugger.so extension for php 5.5.x so if someone in Zend or in community can help, just post a link
I seriously doubt that such a thing will be available for a long time, if ever. Use Xdebug if you need to do 5.5 debugging. As I mentioned in another ticket, they are pushing Zend Server heavily so you will have to wait till they update PHP 5.5 in the server (a year?) before even a 32-bit version is available.

Re: Support for PHP 5.5

Posted: Thu Oct 03, 2013 7:39 pm
by boeve_webdesign
Would be nice to get an reaction from Zend.....

Re: Support for PHP 5.5

Posted: Tue Nov 05, 2013 2:07 pm
by heldchen
our yearly license renewal is coming up, and thus a zend sale called me. i told her we're considering other IDEs as ZS would not support php 5.5. she didn't even knew that the upcoming 10.5 has currently no 5.5 support, whereas competitors have had support since summer. sad.

Re: Support for PHP 5.5

Posted: Thu Jan 02, 2014 8:42 pm
by boeve_webdesign
http://forums.zend.com/viewtopic.php?f=59&t=114838

Finally my question gets answered...

Re: Support for PHP 5.5

Posted: Mon Jan 06, 2014 10:22 pm
by pave1007
I would rather like bug fixes. ZS is still slow as hell. I complained about unusable outline a year ago...