Error creating iOS Run Configuration

General discussion on Zend Studio
Post Reply
chri2386
Posts: 2
Joined: Wed Apr 16, 2014 12:42 am

Error creating iOS Run Configuration

Post by chri2386 » Wed Apr 16, 2014 12:51 am

I am using the free trial version of studio 10.6.1 on Mac OSX (10.9.2). Trying to create run configurations for and IOS. Android configures fine, but when I try to do a new configuration for IOS I get an error (see attached screenshot as well):

An error has occurred. See error log for more details.
3

Checking the Zend Logs reveals an issue with jface

!ENTRY org.eclipse.jface 4 2 2014-04-15 16:39:49.633
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.ArrayIndexOutOfBoundsException: 3
at com.zend.php.ccm.internal.ui.macosx.cmd.IOSSimulator.parseSdks(IOSSimulator.java:224)
at com.zend.php.ccm.internal.ui.macosx.cmd.IOSSimulator.getSdks(IOSSimulator.java:81)
at com.zend.php.ccm.internal.ui.macosx.IOSGeneralTab.initializeValues(IOSGeneralTab.java:210)
at com.zend.php.ccm.internal.ui.macosx.IOSGeneralTab.createControl(IOSGeneralTab.java:87)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.showInstanceTabsFor(LaunchConfigurationTabGroupViewer.java:806)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.displayInstanceTabs(LaunchConfigurationTabGroupViewer.java:737)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer$8.run(LaunchConfigurationTabGroupViewer.java:624)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.inputChanged(LaunchConfigurationTabGroupViewer.java:641)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.setInput0(LaunchConfigurationTabGroupViewer.java:603)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.setInput(LaunchConfigurationTabGroupViewer.java:579)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.handleLaunchConfigurationSelectionChanged(LaunchConfigurationsDialog.java:941)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog$3.selectionChanged(LaunchConfigurationsDialog.java:560)
at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:888)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:886)
at org.eclipse.jface.viewers.StructuredViewer.setSelection(StructuredViewer.java:1726)
at org.eclipse.jface.viewers.TreeViewer.setSelection(TreeViewer.java:1139)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationView.handleConfigurationAdded(LaunchConfigurationView.java:283)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationView.access$1(LaunchConfigurationView.java:272)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationView$2.run(LaunchConfigurationView.java:261)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3946)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3623)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
at org.eclipse.jface.window.Window.open(Window.java:801)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.open(LaunchConfigurationsDialog.java:1132)
at org.eclipse.debug.ui.DebugUITools$2.run(DebugUITools.java:600)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:608)
at org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:542)
at org.eclipse.debug.ui.actions.OpenLaunchDialogAction.run(OpenLaunchDialogAction.java:81)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4136)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1458)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1481)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1466)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1271)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3982)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3621)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

Seems to be a bug in Zend Studio. I do have XCode installed (v 5.1.1) but I think this is unrelated as it's not even showing the configuration screen. Also, the Andorid create works just fine.

Would love to make sure this is fixed and working before I drop $189 on a product. Thanks.
I've tried deleting
Attachments
Screen Shot 2014-04-15 at 4.48.26 PM.png
Error in zend studio trying to create run configuration for iOS
Screen Shot 2014-04-15 at 4.48.26 PM.png (101.42 KiB) Viewed 4320 times

User avatar
wojtek_g
Posts: 57
Joined: Wed Apr 11, 2012 11:05 am

Re: Error creating iOS Run Configuration

Post by wojtek_g » Thu Apr 17, 2014 2:54 pm

Thank you very much for reporting this issue. I have just fixed it and it will be available in next maintenance release (10.6.2) to the end of this month.

Kind regard,
Wojciech Galanciak
Zend Studio Team

chri2386
Posts: 2
Joined: Wed Apr 16, 2014 12:42 am

Re: Error creating iOS Run Configuration

Post by chri2386 » Thu Apr 17, 2014 5:55 pm

Thanks. I look forward to trying the trail again then.

User avatar
natalia_b_zend
Posts: 366
Joined: Wed Jan 25, 2012 5:51 pm

Re: Error creating iOS Run Configuration

Post by natalia_b_zend » Tue May 27, 2014 4:12 pm

This issues has been fixed in 10.6.2 release: http://forums.zend.com/viewtopic.php?f=59&t=118603
Natalia Bartol
Zend Studio Team

vika1644
Posts: 1
Joined: Wed Mar 21, 2018 11:12 pm
Contact:

Re: Error creating iOS Run Configuration

Post by vika1644 » Wed Mar 21, 2018 11:15 pm

Today my MacBook automatically got updated from High Sierra 10.13 to 10.13.4 and now whenever I will open the Zend app it will simply crash on the startup. Has anyone been encountering the same issue after the OS update? How to fix it?

aara5663
Posts: 6
Joined: Tue Dec 19, 2017 9:25 am

Re: Error creating iOS Run Configuration

Post by aara5663 » Sat Jun 30, 2018 6:43 am

Wow, Really great article i enjoy it very much here I appreciating your knowledge keep sharing kindly check it out wifikill

Post Reply