Page 1 of 1

Problem with upgrade to ZS v. 11

Posted: Fri Jul 18, 2014 6:51 pm
by ola_raak
Using Zend Studio 10.6.2.v20140121-20140605-0147-212
When running "Check for updates" command, got following errors:
Cannot complete the install because of a conflicting dependency.
Software being installed: Zend Studio 11.0.0.v20140715-20140711-1248-184 (com.zend.php.ide 11.0.0.v20140715-20140711-1248-184)
Software currently installed: Zend Application Deployment Feature 1.0.0.201405191203 (org.zend.php.zendserver.deployment.feature.group 1.0.0.201405191203)
Only one of the following can be installed at once:
Core 1.0.0.201311261415 (org.zend.php.zendserver.monitor.core 1.0.0.201311261415)
Core 1.0.0.201405191203 (org.zend.php.zendserver.monitor.core 1.0.0.201405191203)
Core 1.0.0.201407091607 (org.zend.php.zendserver.monitor.core 1.0.0.201407091607)
Cannot satisfy dependency:
From: Zend Studio 11.0.0.v20140715-20140711-1248-184 (com.zend.php.ide 11.0.0.v20140715-20140711-1248-184)
To: org.zend.php.zendserver.deployment.all.feature.group [1.0.0.201407091607]
Cannot satisfy dependency:
From: Zend Application Deployment Features 1.0.0.201407091607 (org.zend.php.zendserver.deployment.all.feature.group 1.0.0.201407091607)
To: org.zend.php.zendserver.deployment.feature.group [1.0.0.201407091607]
Cannot satisfy dependency:
From: Zend Application Deployment Feature 1.0.0.201405191203 (org.zend.php.zendserver.deployment.feature.group 1.0.0.201405191203)
To: org.zend.php.zendserver.monitor.core [1.0.0.201405191203]
Cannot satisfy dependency:
From: Zend Application Deployment Feature 1.0.0.201407091607 (org.zend.php.zendserver.deployment.feature.group 1.0.0.201407091607)
To: org.zend.php.zendserver.monitor.core [1.0.0.201407091607]
How to solve this?

Re: Problem with upgrade to ZS v. 11

Posted: Sat Jul 19, 2014 4:38 pm
by vincequeiroz
Get your licence code to version 11 in Zend Panel.

Add your license manually on the file system:
1. Go to the .ZendStudio folder under your user home folder, i.e. C:\Users\[User Account]\.ZendStudio
2. Create a file with name 0_0.
3. Paste your license key as a single line in the file.

Re: Problem with upgrade to ZS v. 11

Posted: Mon Jul 21, 2014 8:05 am
by kaloyan_r
ola_raak, could you download and install a fresh installation of Zend Studio 11?
When you start it for the first time you can point it to your existing workspace.

Re: Problem with upgrade to ZS v. 11

Posted: Wed Jul 23, 2014 2:00 pm
by ola_raak
Thanks for replies.
Solved the problem, downloading and installing fresh ZS11.
And yes, it used existing workspace and settings without problems.