Page 1 of 1

Issue with trying to Deploy svn application

Posted: Wed Aug 27, 2014 6:23 am
by beach_defender
Hi,
I'm using Studio 11 and a local ZendServer on my laptop.

I have just created a new php project from an svn repository, but every time I try to Deploy the application to the Local ZendServer I get the following Error Message.

I don't know how to begin to investigate, does anyone know why this happens and what I need to change?

<error>
"Detected base URL is in conflict with existing "Local Zend Server" server."
</error>

thanks in advance.
Barry

Re: Issue with trying to Deploy svn application

Posted: Mon Sep 01, 2014 11:18 am
by wojtek_g
Hi,

Could you tell me where you see this error? This message means that there is already a server which use the same base URL. In such case you do not need to create a new PHP server again.

Studio detects local Zend Server automatically during startup (you can find it in PHP Servers view). Unfortunately, it does not detect deployment settings so you need to do it manually using following steps:
1. Open PHP Servers view.
2. Double click on Local Zend Server.
3. Go to Deployment tab.
4. Select Enable Zend Deployment.
5. After setting a correct host (host is an address of Zend Server Web GUI, on a local it is usually http://localhost:10081) press Detect Key Details.
6. After Key Name and Key Secret are detected, finish the wizard.

Now your local Zend Server will be visible in deployment wizard.

Let me know if it helps.

Kind regards,

Re: Issue with trying to Deploy svn application

Posted: Fri Dec 19, 2014 6:06 am
by beach_defender
This didn't work for me.


I cant deploy more than one application.

To be honest it makes it too hard to use ZendServer at all.

Can you please fix this, it is not useful.

I have tried to do as you say above but I still get this message.

Why is there not a wizard to help sort it or at least a helpful message to tell you what to do?

Re: Issue with trying to Deploy svn application

Posted: Mon Jan 05, 2015 10:42 am
by wojtek_g
Another possible source of the issue is that you have created your project directly in htdocs folder of a local Zend Server. For example, project called MyProject is created in htdocs of a local Zend Server with http://localhost base URL. In result, http://localhost/MyProject is already used so you cannot deploy application using this URL. In order to avoid this issue you can do one of the following:
- Create project directly in a workspace (change project's location in a New Project wizard)
- Deploy using different URL

Let me know if it helps. Thank you for mentioning issues with usability. I will review this workflow and at least work on better messaging and documentation for it.

Kind regads,