[ZS12] Automatic Upload dir not updated on second deployment

General discussion on Zend Studio
Post Reply
gaborm
Posts: 22
Joined: Fri Jun 26, 2009 10:33 am

[ZS12] Automatic Upload dir not updated on second deployment

Post by gaborm » Mon Dec 01, 2014 11:05 pm

Checked with 12 and 12.0.1EA.

Steps to reproduce:

1. create new workspace
2. create new php project
3. add deployment support
4 deploy to Zend Server 7 (at this point auto upload activated in ZS12 and app dir set to 1.0.0_xx)
5 deploy to Zend Server 7 again

Deploy dir on file system changed to 1.0.0_yy but in ZS12 Automatic Upload settings did not get updated with the new directory --> any change in ZS12 will be saved to the _xx directory but the server will serve form the _yy directory.

Gabor

User avatar
wojtek_g
Posts: 57
Joined: Wed Apr 11, 2012 11:05 am

Re: [ZS12] Automatic Upload dir not updated on second deploy

Post by wojtek_g » Wed Dec 03, 2014 9:54 am

Thank you for reporting the issue. I have just fixed it and will be available in the 12.0.1 release. Unfortunately for now I cannot suggest any workaround except removal of previously deployed application before next deploy.

Kind regards,
Wojciech Galanciak
Zend Studio Team

schnaaf
Posts: 20
Joined: Wed Apr 06, 2011 9:11 am

Re: [ZS12] Automatic Upload dir not updated on second deploy

Post by schnaaf » Wed Dec 03, 2014 10:15 am

Great!

Two questions
1. Is this also fixed for local server deployment?
2. Is this fix available in EA?

User avatar
wojtek_g
Posts: 57
Joined: Wed Apr 11, 2012 11:05 am

Re: [ZS12] Automatic Upload dir not updated on second deploy

Post by wojtek_g » Wed Dec 03, 2014 10:24 am

Yes, it is fixed for both local and remote servers. Unfortunately, it is not available in EA. If the issue is urgent for you, I can provide you a hotfix by sharing updated jar with this fix. In that case I will need exact version of your Studio.
Wojciech Galanciak
Zend Studio Team

schnaaf
Posts: 20
Joined: Wed Apr 06, 2011 9:11 am

Re: [ZS12] Automatic Upload dir not updated on second deploy

Post by schnaaf » Wed Dec 03, 2014 11:48 am

Build ID: 12.0.1.v20141117-20141201-1236-286

gaborm
Posts: 22
Joined: Fri Jun 26, 2009 10:33 am

Re: [ZS12] Automatic Upload dir not updated on second deploy

Post by gaborm » Tue Dec 09, 2014 9:09 am

Thnx Wojciech, looking forward to the release.

Gabor

Post Reply