ZS 12.0.1 64 Bit copy and paste bug

General discussion on Zend Studio
tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by tedtiger » Wed Jan 21, 2015 12:00 pm

Anything new on this subject? Can this issue be addressed?

mich6938
Zend Product Manager
Posts: 352
Joined: Wed Jul 16, 2014 12:32 pm

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by mich6938 » Wed Jan 21, 2015 12:11 pm

I didn't find anything unusual in memory dumps so most probably problem is not related to memory consumption. From thread dump I see that there is problem with reading php file content, but it is unclear if it is synchronization problem or something more "low level". I'm still trying to reproduce it somehow :)

tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by tedtiger » Wed Jan 21, 2015 4:10 pm

I'll try to make a video for you. The source code resides on a network drive shared with Linux and Samba-Server.

mich6938
Zend Product Manager
Posts: 352
Joined: Wed Jul 16, 2014 12:32 pm

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by mich6938 » Wed Jan 21, 2015 6:56 pm

Last piece of information is probably most important. Storing workspace (or just source code) on shared location in the network can cause problems. Network connection is always less reliable then local file system. Can you make experiment and test the same workflow with code on local system? If this will be main problem I will know where I should focus and look for optimization.

tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by tedtiger » Thu Jan 22, 2015 12:56 pm

With local files it's working as exspected. No problems and no hangs. Seems to have something to do with files on network shares.
I've talked to our admin and he said that we're connected fully with gigabit to the network drive "J".

mich6938
Zend Product Manager
Posts: 352
Joined: Wed Jul 16, 2014 12:32 pm

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by mich6938 » Thu Jan 22, 2015 1:22 pm

Thanks for testing it:) I suspected that you ethernet connection will be quite fast, but speed is not ultimate factor. It is possible that operation that is hanging Studio can be optimized (let me know if something similar will happen in different area), but I can't say for sure that something can be done. It is possible that operating system is adding some delay, but I'm just thinking loud right now:) I need some time to investigate this.

User avatar
kaloyan_r
Zend Product Manager
Posts: 582
Joined: Thu May 23, 2013 12:40 pm

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by kaloyan_r » Fri Jan 23, 2015 1:42 pm

Michal, this looks like an old issue discussed in another thread: http://forums.zend.com/viewtopic.php?f=59&t=109513
You can find more details there - like it happens for ZF2 projects. The issue should not be specific to the 64-bit build of Studio.
Kaloyan Raev
Zend Studio Team

tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by tedtiger » Fri Jan 23, 2015 1:56 pm

Indeed looks like they are the same.

mich6938
Zend Product Manager
Posts: 352
Joined: Wed Jul 16, 2014 12:32 pm

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by mich6938 » Thu Apr 16, 2015 9:36 am

Hi,
I think we are close to resolve this issue. If someone still have problem similar to described please try temporary workaround:
  • * Go to Preferences | General | Editors | Text Editors | Hyperlinking
  • * Disable "Zend Framework 2 Hyperlink Detector"
Please let us know if it helps.

tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: ZS 12.0.1 64 Bit copy and paste bug

Post by tedtiger » Tue Apr 21, 2015 7:04 am

It's better now, but sometimes it still stalling for shorter time periods. Especially when code completion ist starting to pop up.

Post Reply