Zend Studio 13 on OSX 10.11 "El Capitan"

General discussion on Zend Studio
alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Fri Oct 09, 2015 9:45 am

Hi,

In the first step, i run an local Zend Server on 10.11. it seems to run, no errors in .../var/log/...

I installed Zend Studio 13 without an error on OSX 10.11, it starts an the Studio said:

Local Zend Server has been detected and can be added to the list of PHP servers. ....

Press "OK" to enable Web API and to add the server, ...

I press "OK" an the he ask me for the "Zend Server Credentials" , admin + Password.
I fill the Password-Box and it don't accept my password ... my password works fine in the Zend Server Adminpage ...
if i want to add the Zend Server manually in the config, i get the same issue.

Does anyone know the problem? or does anyone have a tip where I can look?


Thank you

Greets Alex

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Sun Oct 11, 2015 7:28 pm

Hey Zend Support,

nothing, really nothing ...?

No help for users?


Greets Alex

User avatar
kaloyan_r
Zend Product Manager
Posts: 582
Joined: Thu May 23, 2013 12:40 pm

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by kaloyan_r » Mon Oct 12, 2015 7:37 am

You reported the same issue in this forum topic: http://forums.zend.com/viewtopic.php?f=8&t=128598

My information is that the support team is working actively on your case.
Kaloyan Raev
Zend Studio Team

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Mon Oct 12, 2015 10:02 am

Hi ,

that true, but i get from Zvika the reply:

P.S. - I didn't install Zend Studio yet on OS X 10.11, this is for another forum if problematic...

and

Studio team is checking into the new OS X, I am not aware of their efforts or build status, but you can feel free to raise the topic in the Studio forum.

I agree to Zvika, it is a Studio Problem, and here is the same problem like the first time in the Server Forum, i only need an time plan or an workaround,

only the answer "The Studio Team work on it or checking ..." ... did you work until next year on the problem , it is a litte bit oversharped ... or do you need time until next month, next week, next quarter ...We need a little more information policy, we are your customer NOT your enemys ;-)

For example:

"We find the following issues , on XXXXXXX, we want to check XXXXXX, IMHO we need until XXXXXXX to get work."

It sounds better as "the Studio Team work on the problem" ...*SILENCE* ... eat or die ...(german saying)

Thank you

Alex

User avatar
kaloyan_r
Zend Product Manager
Posts: 582
Joined: Thu May 23, 2013 12:40 pm

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by kaloyan_r » Mon Oct 12, 2015 10:20 am

Copy-pasting things around different communication channels does not really help. It confuses us. And, as I can see, it also confuses you.

I asked the support team before responding to you - they are currently working on your issue.

Please, try to be more patient while we are trying to investigate an issue on a currently unsupported setup.
Kaloyan Raev
Zend Studio Team

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Mon Oct 12, 2015 11:12 am

Thank you for the fast replay,

believe me, a not confused ;-)
1.) i posted through different channels cause i get the the statement : "Sorry, You use OSX 10.11. or better, you need 10.11 -> your fault" or "Sometime maybe it Studio and Server supports 10.11, but i didn't if or when it supports" ...its a summary !
2.) i agree, it is a currently unsupported setup, BUT OSX 10.11 "El Capitan" didn't come from the heaven like an thunderstorm from god "and from now you used this version..." NO,
it come over months with Beta Versions , Goldenmaster, Public Beta Program and so one ... Zend had enough time to check an adapt the software ... you must agree with me?

3.) that true, i open a ticket , but the specialist are in the States, i have a delay of 12Hours, he send me an solution to test and am in the end of work, for example i am cooking ...
then i reply next morning nothing work, i wait 12h for the reply.
Honestly : the solution "restart Zend Server and try" also does not help much.
Other solution, i dont understand, is the the delay problem.

Summary: the post in the Server Forum , are the faster way and i get faster solution as the ticket ...sorry ...

Thank you!

User avatar
gadigold
Posts: 36
Joined: Wed Jan 21, 2009 4:58 pm

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by gadigold » Mon Oct 12, 2015 3:29 pm

Hi Alex,

The Studio's "Detect Local" seems to malfunction when using Studio 13 and Zend Server 8.5.1 on El-Capitan.

The simple workaround for this (till we investigate further) is - click the PHP Servers , Click Add , Click "Remote Zend Server" , add a server name and keep the http://localhost as the URL. Then when promped add your admin password for Server ( or manually add web api keys ) and your server will be added to Studio.

I hope this helps,
Gadi

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Tue Oct 13, 2015 12:44 pm

Hi Gladi,

it works fine (for me as an local Zend Server), i also tested the workaround,manually add an local Zend Server, but i miss the step "add web api key", only the adding of server credentials don'work.
i have to add manually the web api keys in zend Studio.
i generated a test "admin" key and "developer" key (call them admin1 and dev1) on the Zend Server then i use the admin1 key for the manual web api key.

An remote Zend Server don't worked for me.


Thank you Gladi, you helped me a lot!

Greets Alex

dariusz_m
Posts: 19
Joined: Wed Jun 10, 2015 11:26 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by dariusz_m » Tue Oct 13, 2015 1:00 pm

Hi Alex,

Could you attach/send me Studio support file (Help | Support Tool)? It will help us to resolve problem.

Regards,

alex6477
Posts: 24
Joined: Wed Aug 12, 2015 7:55 am

Re: Zend Studio 13 on OSX 10.11 "El Capitan"

Post by alex6477 » Tue Oct 13, 2015 1:27 pm

Hi dariusz_m,

no problem, but can you give me an emailadress, cause
I do not know if private information is contained in the support-files.

Thank you!

Alex

Post Reply