Bug report (Zend Studio 13): Project-wide Foo undefined.

General discussion on Zend Studio
Post Reply
jameskp
Posts: 73
Joined: Fri May 11, 2012 11:55 am

Bug report (Zend Studio 13): Project-wide Foo undefined.

Post by jameskp » Fri Oct 16, 2015 6:42 pm

I'm unsure how to report this bug as I can't provide a code example.

As I was working on a relatively large codebase, the IDE started reporting "Interface Foo undefined" and "Class Bar undefined" for all typehints in all files, on an otherwise working code.

Things I've attempted to rectify the issue:

1. Build > Clean (didn't help).
2. Restart, then Build > Clean (didn't help).
3. Restart, then Build > Clean, then edit every file (like add a space and remove it) then save (removed the errors).

The project is still full of errors as I need to edit every file to get rid of them. Thoughts?

jameskp
Posts: 73
Joined: Fri May 11, 2012 11:55 am

Re: Bug report (Zend Studio 13): Project-wide Foo undefined.

Post by jameskp » Sat Oct 17, 2015 3:02 am

Update: removing the project from the Workspace (without deleting files) then re-importing it worked for a bit. Then after I worked with the project for a while, again everything turned into errors.

tedtiger
Posts: 244
Joined: Thu Mar 05, 2009 4:59 pm
Location: Germany
Contact:

Re: Bug report (Zend Studio 13): Project-wide Foo undefined.

Post by tedtiger » Mon Oct 19, 2015 7:12 am

Try starting ZS with -clean switch on the command line. After ZS has startet clean all projects do a full build and restart ZS.
This solved the problem for me quite often.

Thorsten

jameskp
Posts: 73
Joined: Fri May 11, 2012 11:55 am

Re: Bug report (Zend Studio 13): Project-wide Foo undefined.

Post by jameskp » Mon Oct 19, 2015 10:06 am

Thank you! I tried -clean and I think it's helping. I'll report in this thread if this problem happens a lot and more details.

Post Reply