Debug Configuration PHP Server Changes

General discussion on Zend Studio
Post Reply
sal3415
Posts: 30
Joined: Tue Apr 09, 2013 4:43 am

Debug Configuration PHP Server Changes

Post by sal3415 » Mon Jun 20, 2016 2:46 am

I have a local Zend Server (v9/php7) with many vhosts, and I've accordingly set up each vhost as a Local Zend Server within Zend Studio (v13.5 64bit). I am attempting to debug a given project with two debug configurations (one for index.php - /, and another for zf2.php - /contract/). Whenever I debug using the zf2.php debug configuration (and probably the other one as well - untested), it seems to change the associated PHP Server from 'website' to 'cms', and adjusts the url accordingly. I have to manually change it back for each invocation or it will obviously end up trying to debug the wrong virtual host url. I am concerned that this might have wider ranging implications pertaining to require_once statements only during debug (server/path mapping?), but I will create a separate issue for this in the Zend Server forum in case it is unrelated.

sal3415
Posts: 30
Joined: Tue Apr 09, 2013 4:43 am

Re: Debug Configuration PHP Server Changes

Post by sal3415 » Mon Jun 20, 2016 4:38 am

The require_once component of this problem was fixed by removing all PHP servers within Zend Studio and re-adding them back as 'Remote Zend Server' instead of 'Local Zend Server' entries. The core problem still persists, in that each invocation of debug still changes the designated PHP server for that Run Configuration and has to be manually re-adjusted for each debug.

Post Reply