Zend Studio 8.0.1 & SVN 1.6.12

General discussion on Zend Studio
Post Reply
korrupt
Posts: 2
Joined: Thu May 26, 2011 11:11 am

Zend Studio 8.0.1 & SVN 1.6.12

Post by korrupt » Thu May 26, 2011 11:26 am

Hello,

I've got Zend Studio 8 (updated to 8.0.1) @ work, but I've just problems using it with SVN.

The problems are for example:
  • Commits disappear in a black hole (no output in console, no revision log)
  • I select a folder, press Ctrl+Alt+C, in the commit-window is only a file X listed & selected. When i start the commit, file Y will be commited (which is in a different folder outside the subtree of the selected folder), file X will be ignored without any error
  • I select a folder with 2 changed files (let's call X & Y), press Ctrl+Alt+C and in the commit-windows a file Z is listed which is not part of the selected folder or subfolders)
  • I try to commit new und changed files. The new files will be added, but not commited. Also the changed files will not be commited.
Sometimes the commit works fine, sometimes one of the problems above came up (the most time the first one).
The update always runs without any problems.

Can anyone help to solve the problem?

Im using Ubuntu 10.10 (new install), SVN 1.16.12, Zend Studio 8.0.1 with SVN Kit 1.3.5

ehansmair
Posts: 4
Joined: Thu May 26, 2011 7:17 pm

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by ehansmair » Thu May 26, 2011 7:30 pm

I have the same problems after updating to 8.0.1v20110515255 and SVN-KIt 1.3.5.7406 on a Windows 7 system.

The connection to the SVN repository is lost. I do not get an error message, Eclipse tries a indefinite long time to connect to the repository.

With the Tortoise SVN Client I can continue to work with the SVN repository.

User avatar
sylvie6713
Posts: 311
Joined: Fri Feb 27, 2009 10:24 am
Location: Bulgaria
Contact:

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by sylvie6713 » Fri May 27, 2011 1:18 pm

Hi
We tried to reproduce the problem on various OSs but with no luck.
Do you think you can share some more info that can help?

Thanks
Sylvia Tancheva
QA Team, Zend

ehansmair
Posts: 4
Joined: Thu May 26, 2011 7:17 pm

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by ehansmair » Fri May 27, 2011 4:25 pm

Hi,

what do you need? Is there a logfile which would help?

User avatar
sylvie6713
Posts: 311
Joined: Fri Feb 27, 2009 10:24 am
Location: Bulgaria
Contact:

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by sylvie6713 » Mon May 30, 2011 9:21 am

There should be a .log file located under your workspace\.metadata\
Sylvia Tancheva
QA Team, Zend

ehansmair
Posts: 4
Joined: Thu May 26, 2011 7:17 pm

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by ehansmair » Mon May 30, 2011 6:01 pm

I started a Team / Update on a directory in my source tree. The update show the usual dialog box with "operation in progress...". The detail view show the update with an empty progress bar. In this state Studio is remaining forever. There is no entry in the .log reagarding the svn update operation.

When I try to cancel the svn update operation with the "Cancel" button in the dialog the only reaction is the button turning grey and in the detail view "Update (Cancel Requested)". Again no entry in the .log file. In this state Studio remains for hours.

The only way to continue working is to kill the Studio with task manager.

The .log file for a session with starting Studio, waiting for the DLTK indexer and starting a SVN update looks like this:

Code: Select all

!SESSION 2011-05-30 18:57:07.280 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments:  -showlocation
Command-line arguments:  -os win32 -ws win32 -arch x86 -showlocation

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.007
!MESSAGE System property http.proxyHost is not set but should be 192.168.197.100.

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.007
!MESSAGE System property http.proxyPort is not set but should be 3128.

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.007
!MESSAGE System property https.proxyHost is not set but should be 192.168.197.100.

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.007
!MESSAGE System property https.proxyPort is not set but should be 3128.

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.007
!MESSAGE System property https.proxyHost is not set but should be 192.168.197.100.

!ENTRY org.eclipse.core.net 1 0 2011-05-30 18:57:13.022
!MESSAGE System property https.proxyPort is not set but should be 3128.

!ENTRY org.eclipse.osgi 2 1 2011-05-30 18:57:15.940
!MESSAGE NLS unused message: RemoteServerConfigurationPage_RemoteConfiguratiuon in: com.zend.php.remoteproject.internal.ui.wizard.messages

!ENTRY org.eclipse.osgi 2 1 2011-05-30 18:57:15.940
!MESSAGE NLS unused message: RemoteServerConfigurationPage_formatServerURLError in: com.zend.php.remoteproject.internal.ui.wizard.messages

!ENTRY org.eclipse.osgi 2 1 2011-05-30 18:57:15.940
!MESSAGE NLS missing message: CreateProjectWorkspaceJob_0 in: com.zend.php.remoteproject.internal.ui.wizard.messages

!ENTRY org.eclipse.osgi 2 1 2011-05-30 18:57:15.955
!MESSAGE NLS missing message: CreateProjectWorkspaceJob_1 in: com.zend.php.remoteproject.internal.ui.wizard.messages

korrupt
Posts: 2
Joined: Thu May 26, 2011 11:11 am

Re: Zend Studio 8.0.1 & SVN 1.6.12

Post by korrupt » Mon Jun 06, 2011 8:49 am

Sorry, I was out of office for one week.

I have 2 Exceptions in the log which are thrown very often and maybe helpful:

Code: Select all

!ENTRY org.eclipse.wst.sse.ui 4 4 2011-05-25 14:57:58.183
!MESSAGE null
!STACK 0
org.eclipse.jface.text.BadLocationException
	at org.eclipse.wst.sse.core.internal.text.GenericPositionManager.addPosition(GenericPositionManager.java:84)
	at org.eclipse.wst.sse.core.internal.text.BasicStructuredDocument.addPosition(BasicStructuredDocument.java:870)
	at org.eclipse.wst.sse.ui.internal.style.SemanticHighlightingPresenter.updatePresentation(SemanticHighlightingPresenter.java:471)
	at org.eclipse.wst.sse.ui.internal.style.SemanticHighlightingPresenter$1.run(SemanticHighlightingPresenter.java:404)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3515)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3164)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

Code: Select all

!ENTRY org.eclipse.wst.sse.ui 4 4 2011-05-25 14:47:22.902
!MESSAGE Resource is out of sync with the file system: '/some/path/to/my.file'.
!STACK 1
org.eclipse.core.internal.resources.ResourceException: Resource is out of sync with the file system: '/some/path/to/my.file'.
	at org.eclipse.core.internal.resources.File.checkSynchronized(File.java:103)
	at org.eclipse.core.internal.resources.File.getContentDescription(File.java:273)
	at org.eclipse.wst.sse.ui.internal.actions.FormatActionDelegate.processorAvailable(FormatActionDelegate.java:219)
	at org.eclipse.wst.sse.ui.internal.actions.FormatActionDelegate.processorAvailable(FormatActionDelegate.java:232)
	at org.eclipse.php.internal.ui.actions.format.FormatActionDelegate.selectionChanged(FormatActionDelegate.java:141)
	at org.eclipse.php.internal.ui.actions.FormatDocumentAction.selectionChanged(FormatDocumentAction.java:33)
	at org.eclipse.ui.internal.PluginAction.refreshEnablement(PluginAction.java:206)
	at org.eclipse.ui.internal.PluginAction.selectionChanged(PluginAction.java:277)
	at org.eclipse.ui.internal.PluginAction.selectionChanged(PluginAction.java:299)
	at org.eclipse.ui.internal.AbstractSelectionService.fireSelection(AbstractSelectionService.java:156)
	at org.eclipse.ui.internal.AbstractSelectionService$1.selectionChanged(AbstractSelectionService.java:62)
	at org.eclipse.jface.viewers.Viewer$2.run(Viewer.java:162)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
	at org.eclipse.jface.viewers.Viewer.fireSelectionChanged(Viewer.java:160)
	at org.eclipse.jface.viewers.StructuredViewer.updateSelection(StructuredViewer.java:2162)
	at org.eclipse.jface.viewers.StructuredViewer.handleSelect(StructuredViewer.java:1190)
	at org.eclipse.jface.viewers.StructuredViewer$4.widgetSelected(StructuredViewer.java:1220)
	at org.eclipse.jface.util.OpenStrategy.fireSelectionEvent(OpenStrategy.java:228)
	at org.eclipse.jface.util.OpenStrategy.access$4(OpenStrategy.java:222)
	at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:389)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3540)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3161)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
!SUBENTRY 1 org.eclipse.core.resources 4 274 2011-05-25 14:47:22.902
!MESSAGE Resource is out of sync with the file system: '/some/path/to/my.file'.

Post Reply