Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

General discussion on Zend Studio
Post Reply
sweng2
Posts: 3
Joined: Fri Sep 11, 2009 6:43 pm

Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by sweng2 » Fri Sep 11, 2009 7:21 pm

Hi,

I just did a fresh install of Zend Studio V7.0.1 on Snow Leopard. The first command I tried was "zf show version" using Zend Tool in the Studio. But I got the following, but if run the same command using terminal window, everything works perfectly. Is there some settings that I need to fix this?

executing zf show version
Zend Framework Version: 1.9.2

Failed loading ./ZendDebugger.so: (null)
PHP Warning: PHP Startup: Unable to load dynamic library './ext/bcmath.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/bz2.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/calendar.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/ctype.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/curl.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/exif.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/fileinfo.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/ftp.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/gd.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/imagick.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/json.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/ldap.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mbstring.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mcrypt.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/memcache.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mhash.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mime_magic.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mssql.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mysql.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/mysqli.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/pcntl.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/pgsql.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/posix.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/shmop.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/soap.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/sockets.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/sqlite.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/sysvmsg.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/sysvsem.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/sysvshm.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/tidy.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/tokenizer.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/wddx.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/xmlreader.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/xmlrpc.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/xsl.so' - (null) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './ext/zip.so' - (null) in Unknown on line 0
ok (took 0:02.592)
***

dulepov
Posts: 41
Joined: Thu Apr 09, 2009 8:39 pm

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by dulepov » Fri Sep 11, 2009 9:15 pm

This is easy to answer. Zend debugger is 32-bit while PHP is 64-bit. These two architectures do not work together. You need to run php in 32-bit mode. See "man arch". Or you can try setting environment in .bash_profile like this:

Code: Select all

export "ARCHPREFERENCE=php:/path/to/php:i386"
I am not sure if it affects php when debugging is started from Eclipse. It works from console.
Dmitry Dulepov

sweng2
Posts: 3
Joined: Fri Sep 11, 2009 6:43 pm

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by sweng2 » Fri Sep 11, 2009 10:12 pm

Thank you for your answer.

But if it is caused by the architectural difference, why the same command on terminal window does not have this problem? In addition, Zend Studio 7.0 does not have this problem on Snow Leopard.

sw

User avatar
sylvie6713
Posts: 311
Joined: Fri Feb 27, 2009 10:24 am
Location: Bulgaria
Contact:

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by sylvie6713 » Mon Sep 14, 2009 10:44 am

Hi
Thanks for the post - the bug is reported to the development.
We appreciate your help :)

Sylvia
Sylvia Tancheva
QA Team, Zend

sweng2
Posts: 3
Joined: Fri Sep 11, 2009 6:43 pm

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by sweng2 » Fri Sep 18, 2009 12:43 am

Thank you, Sylvia.

Is there a fix for this?

yang

User avatar
ganoro
Posts: 409
Joined: Wed Jan 21, 2009 5:00 pm

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by ganoro » Fri Sep 18, 2009 7:47 am

You can alter the zf.sh script and add "-c" argument to the php invocation, so no extensions will be loaded.

Roy

mauritzbotha
Posts: 9
Joined: Tue Sep 15, 2009 4:23 am

Re: Zend Studio 7.0.1 Bug? failed to load ZendDebugger.so

Post by mauritzbotha » Thu Sep 24, 2009 7:28 pm

sweng2 wrote:Thank you for your answer.

But if it is caused by the architectural difference, why the same command on terminal window does not have this problem? In addition, Zend Studio 7.0 does not have this problem on Snow Leopard.

sw
I get the same issue on Leopard, never saw it on 7.0, only on 7.0.1. I get it when I right click and start a new "Zend Framework Project" and when I use the "zf create project" option. The "-c" option in the "zf.sh" script did not make a difference

Post Reply