Page 1 of 1

mac os installer needs an update to work with snow leopard

Posted: Wed Sep 23, 2009 6:11 pm
by circumerro
I went to install studio 7.0.1 and got a message that os x 10.6 needs to install rosetta which is what allows it to run apps that are not universal binaries. 10.6 removes rosetta unless you tell the installer to install it. It seems that your installer needs to be updated as a universal binary.

Re: mac os installer needs an update to work with snow leopard

Posted: Wed Sep 23, 2009 7:00 pm
by vuolot
I get the same message. I can't update Zend Studio 7 using the updater because of the

Code: Select all

An error occurred while unconfiguring the items to uninstall
  session context was:(profile=studioProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Unconfigure, operand=[R]org.eclipse.equinox.launcher 1.0.200.v20090520 --> [R]org.eclipse.equinox.launcher 1.0.200.v20090904, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.RemoveProgramArgumentAction).
  Error while loading manipulator.
  Error while loading manipulator.
problem. And I can't install 7.0.1 on Snow Leopard without installing Rosetta.

The updater issue should be resolved by now. That's disappointing Zend, especially for those that wish to install additional plugins or save bandwidth on a full download.

Re: mac os installer needs an update to work with snow leopard

Posted: Sat Apr 10, 2010 2:37 pm
by akede
The fun part is that this is only an issue with the installer itself. I upgraded a Mac and there the ZendStudio was copied from the old computer to the new one. Zend Studio works nice, however when I call the installer it tells me that Rosetta is not installed. Yes it is not installed.

Interesting, may be you unpack it on an old computer and just copy it.

Alex