Zend Studio executable doesn't appear to work:

General discussion on Zend Studio
Post Reply
srflaxu40
Posts: 3
Joined: Wed Feb 01, 2012 7:35 pm

Zend Studio executable doesn't appear to work:

Post by srflaxu40 » Wed Feb 01, 2012 7:38 pm

Hi, everyone.

I am trying to install Zend Studio on my Fedora box, but the executable appears to do nothing. I have extracted it properly, moved into the ZendStudio directory, and issued the following:

[john@John ZendStudio]$ ./ZendStudio
[john@John ZendStudio]$

Permissions appear to be fine:

[john@John ZendStudio]$ ls -l
total 584
drwxrwxrwx. 2 john john 4096 Dec 14 13:29 about_files
-rwxrwxrwx. 1 john john 577 Jun 1 2011 about.html
-rwxrwxrwx. 1 john john 132254 Dec 14 13:29 artifacts.xml
drwxrwxrwx. 4 john john 4096 Dec 14 13:29 configuration
drwxrwxrwx. 2 john john 4096 Feb 1 13:31 docs
drwxrwxrwx. 83 john john 12288 Dec 14 13:29 features
-rwxrwxrwx. 1 john john 52546 Dec 14 13:26 icon.xpm
-rwxrwxrwx. 1 john john 266168 Jun 1 2011 libcairo-swt.so
drwxrwxrwx. 4 john john 4096 Dec 14 13:28 p2
drwxrwxrwx. 25 john john 36864 Dec 14 13:29 plugins
-rwxrwxrwx. 1 john john 62814 Jun 1 2011 ZendStudio
-rwxrwxrwx. 1 john john 301 Dec 14 13:29 ZendStudio.ini

Does anyone have any advice? Thanks!

John

User avatar
ericritchie
Posts: 118
Joined: Tue Feb 10, 2009 10:09 am

Re: Zend Studio executable doesn't appear to work:

Post by ericritchie » Thu Feb 02, 2012 10:45 am

Hi John,

Silly question: Do you have a JRE installed? AFAIK this is not distributed with the Linux version of Studio.

Hope this helps,
Eric.

srflaxu40
Posts: 3
Joined: Wed Feb 01, 2012 7:35 pm

Re: Zend Studio executable doesn't appear to work:

Post by srflaxu40 » Thu Feb 02, 2012 3:21 pm

Hi, Eric.

Thanks for the help! However, I did manually install the JDK 6 / JRE, and still get the following:

[root@John ZendStudio]# java -version
java version "1.6.0_25"
Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
Java HotSpot(TM) Server VM (build 20.0-b11, mixed mode)

[root@John ZendStudio]# ./ZendStudio
[root@John ZendStudio]#

Any further ideas with what might be occurring? Thanks again!

Best,

John

User avatar
ganoro
Posts: 409
Joined: Wed Jan 21, 2009 5:00 pm

Re: Zend Studio executable doesn't appear to work:

Post by ganoro » Thu Feb 02, 2012 5:30 pm

Can you run it with -console -debug and send out the error log?

srflaxu40
Posts: 3
Joined: Wed Feb 01, 2012 7:35 pm

Re: Zend Studio executable doesn't appear to work:

Post by srflaxu40 » Thu Feb 02, 2012 6:43 pm

Hi, everyone.

Thank you for the help,but after much troubleshooting, and a little naivete on my behalf, I have it up and running. The issue was being sure I installed both the 64-bit versions of ZendStudio, and the JDK / JRE. I think I may have fumbled a click, and downloaded the wrong version of ZendStudio by mistake. Apologies, but thanks for everyone's persistence and help!

Best,

John

Post Reply