Zend Studio upgrade April 20th broken

General discussion on Zend Studio
marketacumen
Posts: 19
Joined: Thu Jul 15, 2010 9:03 pm

Zend Studio upgrade April 20th broken

Post by marketacumen » Sun Apr 22, 2012 11:28 pm

Upgrading Zend Studio 9 (Build ID: 20120405) on Mac OS X Lion today component "Zend Studio 9.0.3.v20120420435" to the latest breaks the application with this message:

"The Zend Studio executable launcher was unable to locate its companion shared library."

I upgraded twice, first updating everything, then just this component in Zend Studio. Both gave a dialog with the above message after upgrading.

Thankfully, I could go back to a previous version of the software from backup, but this is somewhat discouraging.

Any help please? I'd rather not use the Beta site, but I'm surprised you put up an update that breaks the core.
No whining.

User avatar
ilina_s
Posts: 20
Joined: Thu Apr 26, 2012 3:45 pm

Re: Zend Studio upgrade April 20th broken

Post by ilina_s » Fri Apr 27, 2012 11:25 am

Hi
I experienced the same behavior before. I tried to reproduce it now, but could not. Please, try now or with the next build and if anything wrong, let me know. Thanks.
Ilina
Zend Studio QA Team

User avatar
rbzend
Zend Global Support
Posts: 536
Joined: Tue Dec 23, 2008 5:03 pm

Re: Zend Studio upgrade April 20th broken

Post by rbzend » Fri Apr 27, 2012 2:10 pm

Yes, unfortunately this is the flip-side of using the latest software.
We will have the next build up on the beta site tomorrow (around 5am EDT), try it then and let us know, if there still are issues with the update.
Roman Basayev
Rogue Wave Support
https://support.roguewave.com/

marketacumen
Posts: 19
Joined: Thu Jul 15, 2010 9:03 pm

Re: Zend Studio upgrade April 20th broken

Post by marketacumen » Tue May 01, 2012 3:09 am

I just double-checked and actually I am checking against the beta server. When I disable those update servers, no updates occur.

As a FYI, it still doesn't work on Mac OS X for the beta update: Zend Studio 9.0.3.v20120427437

Same error, a dialog which says:

"The Zend Studio executable launcher was unable to locate its
companion shared library."

If you want a log file to help, let me know. Otherwise, I'll wait for the production version.
No whining.

4worx
Posts: 9
Joined: Tue Aug 11, 2009 3:54 pm

Re: Zend Studio upgrade April 20th broken

Post by 4worx » Thu May 10, 2012 8:20 am

Is there any news regarding this issue? Today (May 10th) I upgraded my Zend Studio beta version and got the same message after restart.

4worx
Posts: 9
Joined: Tue Aug 11, 2009 3:54 pm

Re: Zend Studio upgrade April 20th broken

Post by 4worx » Thu May 10, 2012 8:29 am

Using ./ZendStudio -clean I saw what the problem was:

It couldn't dlopen org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502 located in Resources/Java/plugins.
Symbolic linking it:

Code: Select all

ln -s org.eclipse.equinox.launcher.cocoa.macosx_1.1.101.v20120109-1504 org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502
Partly solves the problem. Running Zend Studio via the clean method works. The normal way still fails with the same error.

lfolco
Posts: 1
Joined: Thu May 10, 2012 11:20 pm

Re: Zend Studio upgrade April 20th broken

Post by lfolco » Thu May 10, 2012 11:20 pm

hi-

i just upgraded and have the same problem. how can i roll this update back? i'm dead in the water :\

User avatar
kalinyanev
Posts: 90
Joined: Thu Jul 02, 2009 7:20 am

Re: Zend Studio upgrade April 20th broken

Post by kalinyanev » Mon May 14, 2012 12:14 pm

Hi,
I am trying to reproduce the problem, but without success, yet.
Did you create any particular project in advance (before performing the upgrade)?
Which extra features did you install before upgrading?
Any additional details about your workspace will be helpful.

Thanks,
Kalin Yanev
Zend QA Team

netikala
Posts: 6
Joined: Wed Oct 19, 2011 2:15 pm

Re: Zend Studio upgrade April 20th broken

Post by netikala » Tue May 15, 2012 9:44 am

i have the same issue , last update was anyedit tools related and prior that zend studio9 last uopdates

netikala
Posts: 6
Joined: Wed Oct 19, 2011 2:15 pm

Re: Zend Studio upgrade April 20th broken

Post by netikala » Tue May 15, 2012 9:50 am

i get this

Code: Select all

dlopen(../Resources/Java/plugins/org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502, 2): image not found

Post Reply