Zend Studio upgrade April 20th broken

General discussion on Zend Studio
emeacham
Posts: 1
Joined: Thu May 03, 2012 12:54 pm

Re: Zend Studio upgrade April 20th broken

Post by emeacham » Tue May 15, 2012 7:23 pm

I too am getting "image not found"

Code: Select all

$ ./Zend\ Studio.app/Contents/MacOS/ZendStudio -clean
dlopen(../Resources/Java/plugins/org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502, 2): image not found

eggnaube
Posts: 3
Joined: Mon May 14, 2012 6:22 pm

Re: Zend Studio upgrade April 20th broken

Post by eggnaube » Wed May 16, 2012 10:01 am

Same problem here, with ZS 9.0.3.201205071416. Problem occurred after uninstalling a eclipse plugin. A symbolic link, as described in the post above, helps to start ZS with './ZendStudio -clean'.

netikala
Posts: 6
Joined: Wed Oct 19, 2011 2:15 pm

Re: Zend Studio upgrade April 20th broken

Post by netikala » Wed May 16, 2012 10:33 am

reinstall solved it but now getting a lot of

Code: Select all

An internal error occurred during: "Compute launch button tooltip".
org/eclipse/php/internal/debug/core/preferences/PHPProjectPreferences

User avatar
kalinyanev
Posts: 90
Joined: Thu Jul 02, 2009 7:20 am

Re: Zend Studio upgrade April 20th broken

Post by kalinyanev » Thu May 17, 2012 7:36 am

Hi,
I reproduced the problem on both Mac Leon and Mac Snow Leopard and filed an issue in our bug-tracking system.
I would like to thank you all for co-operation and constructive comments.

Thanks,
Kalin Yanev
Zend QA Team

User avatar
kalinyanev
Posts: 90
Joined: Thu Jul 02, 2009 7:20 am

Re: Zend Studio upgrade April 20th broken

Post by kalinyanev » Thu May 17, 2012 9:10 am

Hi,
Please, use the next workaround:
In Terminal:
Go to /Applications/Zend Studio.app/Contents/Resources/Java/ZendStudio.app/Contents/MacOS
Run: "./ZendStudio -clean"

Thanks,
Kalin Yanev
Zend QA Team

panosru
Posts: 135
Joined: Mon Mar 02, 2009 2:40 pm
Location: Greece
Contact:

Re: Zend Studio upgrade April 20th broken

Post by panosru » Fri May 18, 2012 5:24 am

Hi, with -clean flag through terminal it work but it's annoying to have to run terminal every time you need to open zend studio, isn't there any other more efficient work-around? This happened to me after I installed the 9.0.3 update on Zend Studio.
INTERACTIVE WEB SOLUTIONS | Zend PHP 5 Certified Engineer
PHP Development / Zend Framework / jQuery / XHTML / CSS
-----------------------------------------------
Online CV: http://www.panosru.com/
-----------------------------------------------

User avatar
kalinyanev
Posts: 90
Joined: Thu Jul 02, 2009 7:20 am

Re: Zend Studio upgrade April 20th broken

Post by kalinyanev » Fri May 18, 2012 2:23 pm

Hi,
Please, unzip the attached .zip file in your plugins folder (/Applications/Zend Studio.app/Contents/Resources/Java/plugins).
e.g. run in Terminal:

unzip "/Users/studio/Downloads/org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502.zip" -d "/Applications/Zend Studio.app/Contents/Resources/Java/plugins/"

Then double-click on "Zend Studio" executable file in Applications. Zend Studio should be launched properly.
Let me know if it works.

Thanks,
Kalin Yanev
Zend QA Team
Attachments
org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502.zip
(47.82 KiB) Downloaded 612 times

panosru
Posts: 135
Joined: Mon Mar 02, 2009 2:40 pm
Location: Greece
Contact:

Re: Zend Studio upgrade April 20th broken

Post by panosru » Fri May 18, 2012 2:29 pm

@kalinyanev Thanks for that! before I try it I want to ask if this will remove any plugins I have already installed or if I should take backup of the folder before I unzip into plugins...

Thanks! :)
INTERACTIVE WEB SOLUTIONS | Zend PHP 5 Certified Engineer
PHP Development / Zend Framework / jQuery / XHTML / CSS
-----------------------------------------------
Online CV: http://www.panosru.com/
-----------------------------------------------

User avatar
kalinyanev
Posts: 90
Joined: Thu Jul 02, 2009 7:20 am

Re: Zend Studio upgrade April 20th broken

Post by kalinyanev » Fri May 18, 2012 2:41 pm

Hi,
Better always prepare backup in advance, it is a general rule :)
Then try it.

Kalin Yanev
Zend QA Team

panosru
Posts: 135
Joined: Mon Mar 02, 2009 2:40 pm
Location: Greece
Contact:

Re: Zend Studio upgrade April 20th broken

Post by panosru » Fri May 18, 2012 3:13 pm

Worked fine! Thanks for that!

Also for people who will use terminal with root user they probably will see a window like this when they try to run Zend Studio:

Image

Then you should chown couple of directories to your actual user account.

I run the following commands:

Code: Select all

# chown -R panosru:admin /Applications/Zend\ Studio.app/Contents/Resources/Java/plugins/org.eclipse.equinox.launcher.cocoa.macosx_1.1.100.v20110502/
# chown -R panosru:admin /Applications/Zend Studio.app/Contents/Resources/Java/configuration/org.eclipse.osgi/
and everything works just fine again! Obviously you will replace "panosru" with your own user :)

Also I took backup of my plugins folder just in case but everything is ok, nothing missing so no need for backup, but still take a backup just in case!

Cheers
INTERACTIVE WEB SOLUTIONS | Zend PHP 5 Certified Engineer
PHP Development / Zend Framework / jQuery / XHTML / CSS
-----------------------------------------------
Online CV: http://www.panosru.com/
-----------------------------------------------

Post Reply