Page 1 of 2

Autocomplete brakes on 7.2

Posted: Mon May 03, 2010 9:31 pm
by shurika
Hey all,

I have updated my studio to version 7.2 and everything was working fine some time; but at some point autocomplete functionality broke.
I'm getting an error: 'No Default proposals' or 'No template proposals' and see attachment.

What can be a problem, and how to fix it?

Re: Autocomplete brakes on 7.2

Posted: Tue May 04, 2010 6:44 am
by crazymerlin
Pasting the contents of your .buildpath file would really help, if you can.

Re: Autocomplete brakes on 7.2

Posted: Tue May 04, 2010 6:52 am
by shurika
Sure...

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<buildpath>
	<buildpathentry kind="src" path=""/>
	<buildpathentry kind="con" path="org.eclipse.php.core.LANGUAGE"/>
</buildpath>

Re: Autocomplete brakes on 7.2

Posted: Tue May 04, 2010 10:01 pm
by shurika
Any idea?

Re: Autocomplete brakes on 7.2

Posted: Wed May 12, 2010 8:23 am
by ins1de
I have the same problem.
I've fixed it by deleting the folowing file:
Zend/workspaces/<your workspace name>/.metadata/.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ui.prefs

And restart Zens Studio after this

Re: Autocomplete brakes on 7.2

Posted: Wed May 12, 2010 4:58 pm
by shurika
ins1de wrote:I have the same problem.
I've fixed it by deleting the folowing file:
Zend/workspaces/<your workspace name>/.metadata/.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ui.prefs

And restart Zens Studio after this
Thanks a lot!
That helped.
I wonder what the problem exactly was. Unfortunately I deleted this file without looking into it.
What is this file for in a first place?

Re: Autocomplete brakes on 7.2

Posted: Sat May 15, 2010 7:14 pm
by tzvikaziv
I have similar problem, templates autocomplete works but Zend does not complete the variables names and php functions.
The solution from above does not working for me, any other ideas?

Thanks

Re: Autocomplete brakes on 7.2

Posted: Thu Jun 03, 2010 3:19 pm
by neospam
The solution above really works! Thanks a lot.
File contents:

Code: Select all

#Fri May 07 15:35:36 MSD 2010
useAnnotationsPrefPage=true
content_assist_disabled_computers=org.eclipse.dltk.ui.scriptNoTypeProposalCategory\u0000org.eclipse.dltk.ui.defaultProposalCategory\u0000org.eclipse.dltk.ui.scriptTypeProposalCategory\u0000
eclipse.preferences.version=1
sourceHoverBackgroundColor.SystemDefault=true
org.eclipse.dltk.ui.methodreturntype=true
sourceHoverBackgroundColor=255,255,225
useQuickDiffPrefPage=true
The same problem in Zend Studio Eclipse appears many times for me since 6 version. I'm really tired from it, once in 3 months removing configuration directory and configuring Zend Studio from the beginning.
Thanx again!

Re: Autocomplete brakes on 7.2

Posted: Sun Jun 06, 2010 9:21 am
by rbzend
tzvikaziv wrote:I have similar problem, templates autocomplete works but Zend does not complete the variables names and php functions.
The solution from above does not working for me, any other ideas?
Thanks
This may help:
Built-In PHP Functions Are Not Recognized

Re: Autocomplete brakes on 7.2

Posted: Fri Nov 05, 2010 8:01 pm
by parannoyed
Removing the the line starting with:

Code: Select all

content_assist_disabled_computers=
from the from the file mentioned below solved this for me.

Thanks ins1de.
ins1de wrote:I have the same problem.
I've fixed it by deleting the folowing file:
Zend/workspaces/<your workspace name>/.metadata/.plugins/org.eclipse.core.runtime/.settings/org.eclipse.dltk.ui.prefs

And restart Zens Studio after this