i5_COMD service does not get started at IPL

General discussion on Zend Core for IBM System i

i5_COMD service does not get started at IPL

Postby varshak on Fri Mar 18, 2011 4:36 pm

Hi all,
We are having problem to start the I5_COMD service at IPL start up. We automatically IPL our server every Saturday late night after our backup gets completed.
During IPL everything under Zend subsystem starts except i5_comd daemon.

ZEND QSYS SBS .0 DEQW
ZC_STR_PRN ZENDADMIN BCI .0 PGM-prngd SELW
ZENDCOREAP ZENDADMIN BCI .0 PGM-httpd SELW
ZENDCOREAP ZENDADMIN BCI .0 PGM-httpd DEQW
ZENDCOREAP ZENDADMIN BCI .0 PGM-httpd SELW
ZENDCOREAP NOBODY BCI .0 PGM-httpd TIMW
ZENDCOREAP NOBODY BCI .0 PGM-httpd TIMW
ZENDCOREAP NOBODY BCI .0 PGM-httpd TIMW
ZENDCOREAP NOBODY BCI .0 PGM-httpd TIMW
ZENDCOREAP NOBODY BCI .0 PGM-httpd TIMW


Even I tried writing separate program and called that one in Job schedular to start the Zend subsystem (for testing, first ended all the jobs and zend susbsystem.) But I5_comd did not started.
When I saw the job log I found the the program got called successfully to start the I5_COMD but later two threads or two programs got submitted automatically to end it.

Here is the job log...

:
1908 - ZENDCORE/ZCCSTREACD LIB(ZENDCORE) PORT(6078) PJ(*ON)
RESTART(*YES)
1000 - QSYS/CALL PGM(ZENDCORE/ZCCENDEACD)
500 - QSYS/CALL PGM(ZENDCORE/ZCCPORT001) /* The CALL command
contains parameters */
:
:


I only wrote code "STRSBS SBSD(ZENDCORE/ZEND) " in my calling program, but I am not sure why and how "QSYS/CALL PGM(ZENDCORE/ZCCENDEACD) " and "QSYS/CALL PGM(ZENDCORE/ZCCPORT001) " got submitted immediately after ZCCSTREACD which starts the i5_COMD daemon.

The only solution works to start i5_COMD is from Go ZENDCORE/ZCAMENU and option 8 "Start i5_COMD service” which actually calls same program ZCCSTREACD. Only from menu option this program works not from calling outside on command line.
There is not a problem to use menu option, but we wanted to do this automatically at IPL or after IPL to avoid manual effort by someone.

Can anyone know solution on auto startup i5_comd service at IPL or solution to above problem?
Thanks in advance,

Varsha
varshak
 
Posts: 1
Joined: Fri Mar 18, 2011 4:02 pm

Return to Zend Core for i5/OS

Who is online

Users browsing this forum: No registered users and 1 guest