i5: autostart Zend after IPL

General discussion on Zend Core for IBM System i
Post Reply
mkopsch
Posts: 3
Joined: Mon Jan 04, 2010 5:44 pm

i5: autostart Zend after IPL

Post by mkopsch » Mon Jan 04, 2010 5:52 pm

Hello all,

I'm making my first experiences with Zend on the AS400. The problem at hand is, that the apache jobs are not startet with IPL. I have installed ZendCore 2.6.1 on a fresh i5/OS 6.1 server.
I've already changed the QSTRUPPGM according to knowledge base article http://www.zend.com/support/knowledgeba ... iew_only=1.

What happens is, that port 89 becomes active and I can see the welcome page of Zend Core. As soon as I try to log into the user interface I get a HTTP response code of 503 Service unavailable. On port 8000 nothing is running. If I restart the Zend subsystem everything works.

When I change the loglevel on the job descriptions for ZCOREJOBD and ZCOREJOBDA, I get logs for the job ZC_STR_ASJ when starting Zend manually. If I leave those descriptions active I get no logs after IPL.

Can one of you guys please give me a hint into the right direction?

Many thanks in advance

mkopsch
Posts: 3
Joined: Mon Jan 04, 2010 5:44 pm

Re: i5: autostart Zend after IPL

Post by mkopsch » Tue Jan 05, 2010 3:58 pm

Hello again,

I did some further research in hope it would lead me to somewhere. Actually I can see, that ZC_STR_ASJ is called and ends with a return code of 0. Within this job a ZENDCOREAP job gets started which makes a call to the qp2shell and should start the apache instance and create a file httpd.pid.
In the next step the job checks for a file called httpid.pid
So I changed the pid filename in httpd.conf to httpid.pid, but with no improvement seen.

I will attach the joblog in hope anyone can help me.

The ZEND subsystem gets active, but it only contains the following jobs.

Code: Select all

I5_COMD      QTCP        BCH     0,0  PGM-EASYCOMD     TIMW
ZC_STR_PRN   ZENDADMIN   BCI     0,0  PGM-prngd        SELW
In Apaches errorlog I get a message:
[Tue Jan 05 15:27:05 2010] [warn] Init: PRNG still contains insufficient entropy!
[Tue Jan 05 15:27:05 2010] [error] Init: Failed to generate temporary 512 bit RSA private key
Configuration Failed

I suspect it's a different issue, but it doesn't harm anyone if I post all information I've got.

Any help would be appreciated.
Attachments
QPJOBLOG021478.txt
(98.43 KiB) Downloaded 698 times

mkopsch
Posts: 3
Joined: Mon Jan 04, 2010 5:44 pm

Re: i5: autostart Zend after IPL

Post by mkopsch » Wed Jan 06, 2010 10:25 am

I've found the solution here:
viewtopic.php?p=8892#p8892

It really helped to add those lines to the httpd.conf

Post Reply