[PHPMYADMIN] 127.0.0.1 instead my correct server ip

General discussion on Zend Core for IBM System i
Post Reply
serin
Posts: 1
Joined: Mon Mar 22, 2010 2:59 pm

[PHPMYADMIN] 127.0.0.1 instead my correct server ip

Post by serin » Mon Mar 22, 2010 3:06 pm

I have installed phpmyadmin on my iseries.
When I'm triyng to connect to phpmyadmin using for example the url http://192.168.1.12/phpmyadmin/index.php I'll be redirected to a page with initial 127.0.0.1 on the url.
For example:

http://127.0.0.1:89/phpadmin/index.php? ... 2d3eed1ea5

If I set my correct server ip, 192.168.1.12, instead 127.0.0.1 it will work correctly. I can enter in phpmyadmin and apply all my configuration.

Also, if I use http like "auth mode" instead cookie I have no problem, but I wish to use cookie :-D

Where I fall?

This is part of my phpmyadmin config:

/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = '192.168.1.12';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = false;

THanks to all

chris_hird
Posts: 171
Joined: Fri Apr 10, 2009 12:41 am
Location: Toronto
Contact:

Re: [PHPMYADMIN] 127.0.0.1 instead my correct server ip

Post by chris_hird » Thu Apr 08, 2010 1:03 am

Make sure the Proxy Preserve Host is set. Post your configs, its nothing to do with phpMyAdmin but your HTTP server set up.
You are also seeing 127.0.0.1:89 which is saying to me that your Proxy server is returning the page not your webserver which is calling the Proxy server!

If you need to see how to set up the servers take a look at my blog, I have lots of information there to help.

http://www.shield.on.ca/Blog

Chris...
Shield Advanced Solutions Ltd
Home of JobQGenie and the Receiver Apply Program
http://www.shield.on.ca/Blog

Post Reply