Page 1 of 1

Report Problems As You Type not working

PostPosted: Wed Jun 18, 2014 7:45 pm
by moellenbdoorcounty
In Zend Studio 8 when I would have a syntax error in the PHP code such as missing the closing bracket in an IF group or missing the semi-colon at the end of a code line, the editor would put a red circle with X in the left margin with a hover message explaining the syntax error, and also red marks in the right margin. In version 9 I never could get this to work. Today I downloaded a trial version of 10.6, and here I am also not getting the syntax checking. In all three versions the Report Problems As You Type box is checked in Windows-Preferences-General-Editors-Structured Text Editors. I have tried 9 on two different PCs (XP and Win7) and get the same results. Have tried same .php file in all three versions: works in 8, not in 9 or 10.6. Suggestions??

Re: Report Problems As You Type not working

PostPosted: Fri Nov 07, 2014 10:41 pm
by moellenbdoorcounty
With help from Zend Support we have finally resolved this problem.

The simple answer appears to be that in Zend Studio 9 and higher the PHP file must be associated with a PHP Project in order for the "Report Problems As You Type" function to work. As soon as I associate a PHP file with a Project, the PHP editor reports syntax problems as I type.

I had never used the Project organization before within Zend Studio, but had simply organized each application within its own separate folder. So none of the PHP files here have been associated with a Project. I will need to change that practice in the future and always use the Project organization within Zend Studio so that the "Report Problems As You Type" feature will work.

Still, it is hard to understand why this should matter. If one is editing a PHP file within the PHP perspective, why should it matter that the file is associated with a Project? Clearly it did not matter in Zend Studio 8.0, but is a requirement in later versions.

Re: Report Problems As You Type not working

PostPosted: Thu Feb 23, 2017 7:27 am
by sami355
Many cases we will get this problems in Zend Studio 8 . As you using you will find why its happens like this errors. You can be able to fix this problem .

Re: Report Problems As You Type not working

PostPosted: Tue Mar 21, 2017 12:01 pm
by bran3466
Are these servers proper for educational use?