Studio 8.0.1 and IBM i V7.R1 TR11 Problems

General discussion on Zend Studio for IBM System i

Studio 8.0.1 and IBM i V7.R1 TR11 Problems

Postby joewhitlock on Tue Jan 05, 2016 4:10 pm

We recently updated our Power 7 to TR11. After this change, I tried to connect my Zend Studio and received the following message. sshd[1258]: fatal: ssh_dispatch_run_fatal: Connection to 192.168.130.60: no matching key exchange method found.

Will upgrading Zend Studio to the latest and greatest allow me to connect using SSHD like I always have?

Thanks.
joewhitlock
 
Posts: 7
Joined: Thu Jan 06, 2011 8:54 pm

Re: Studio 8.0.1 and IBM i V7.R1 TR11 Problems

Postby erich_hieden on Thu Jan 14, 2016 3:06 pm

Hello Joe

I had the same problem with ZendStudio 9 and after changing to V7R2. Problem was that the KeyExchanges 'diffie-hellman-group-exchange-sha1' & 'diffie-hellman-group1-sha1' weren't available anymore.

After adding the following line to /QOpenSys/QIBM/UserData/SC1/OpenSSH/etc/sshd_config
Code: Select all
KexAlgorithms curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1

and restarting the sshd (STRTCPSVR & ENDTCPSVR) it worked again.

Switching to the current ZendStudio version (12+) would have worked too.

Best
erich_hieden
 
Posts: 393
Joined: Tue Jul 07, 2009 9:01 am


Return to Zend Studio for IBM i

Who is online

Users browsing this forum: No registered users and 2 guests